Closed Bug 1338792 Opened 6 years ago Closed 6 years ago

Selecting text followed by clearing the selection flashes the dynamic toolbar even if dynamic toolbar is hidden

Categories

(Firefox for Android Graveyard :: Toolbar, defect, P3)

54 Branch
All
Android
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pwrjazz, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170210030206

Steps to reproduce:

Make sure Full Screen Browsing is enabled.

Go to any page with text that is easily selected.  Scroll down such that the dynamic toolbar is hidden completely.

Select some text.  The text selection toolbar appears.

Tap anywhere else on the page to clear the selection.


Actual results:

The text selection toolbar disappears, followed by a quick flash of the dynamic toolbar before it too disappears.


Expected results:

Since the dynamic toolbar is already hidden, it should never display in the first place, i.e. the text selection toolbar should disappear, and that's it.
I assume this affects only older Android versions that don't get the floating text selection menu bar.
Yeah, I can repro it on my Z3C running CM 12.1 (~ Android 5.1.1). It's a very quick flash, maybe one or two frames, and I only noticed it because I was looking for it this time. Never noticed it before, although I've done that action many times.
Status: UNCONFIRMED → NEW
Depends on: dynamic-toolbar-3
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
This is fixed by bug 1358554 in the new dynamic toolbar rewrite.
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 1358554
Resolution: --- → FIXED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.