Most visited tab displays the URL of IDN in Punycode transcription.

RESOLVED DUPLICATE of bug 1258959

Status

()

Firefox
New Tab Page
RESOLVED DUPLICATE of bug 1258959
a year ago
a year ago

People

(Reporter: Frédéric Bolvin, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8836455 [details]
Screenshot_20170212_123409.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161214021728

Steps to reproduce:

- Open a web site with an international domain name several times so it will appear in the most visited tab.
- You will see the IDN in the adress line as expected, DNS requests internal are done in punnycode.
- Open the most visited sites tab.
- You see the domain name of the site in punnycode transcription.


Actual results:

URL of the site in the most visited tab is displayed in punnycode transcription.


Expected results:

URL of the site in the most visited tab should be displayed the same way, the user will see it in the address line.

Updated

a year ago
Component: Untriaged → Networking
Product: Firefox → Core
Component: Networking → New Tab Page
Product: Core → Firefox

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Last Resolved: a year ago
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1258959
You need to log in before you can comment on or make changes to this bug.