Closed Bug 1339038 Opened 3 years ago Closed 3 years ago

several jobs fail on taskcluster-worker in resource leak test

Categories

(Taskcluster :: Workers, defect, P1)

x86_64
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla54

People

(Reporter: wcosta, Assigned: wcosta)

References

Details

User Story

mochitest-e10s, bc3,bc5,bc6,bc7
bc2 non-e10s
and mochitest-2 non-e10s

Attachments

(2 files)

User Story: (updated)
Summary: mochitests-browser-chrome-2 fails on taskcluster-worker → several jobs fail on taskcluster-worker in resource leak test
Duplicate of this bug: 1339037
User Story: (updated)
Assignee: nobody → wcosta
Status: NEW → ASSIGNED
Some tests fail if we don't use the host TMPDIR path.
Attachment #8840151 - Flags: review?(dustin)
There are some environment variables necessary to run test jobs in BB
which are also necessary for taskcluster-worker. They were copied from
[1].

Additionally, native-engine was broken by bug 1325701. We fix it in this
commit.

[1] https://github.com/mozilla-releng/build-buildbotcustom/blob/master/env.py#L89-L96
Attachment #8840156 - Flags: review?(dustin)
Attachment #8840151 - Flags: review?(dustin) → review+
Attachment #8840156 - Flags: review?(dustin) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f608a5a5d8e2
Replicate BB environment variables. r=dustin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f608a5a5d8e2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Component: Worker → Workers
You need to log in before you can comment on or make changes to this bug.