Closed Bug 1339062 Opened 3 years ago Closed 3 years ago

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mats)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

:jet - This Android-only reftest failure is very frequent. Can you find someone to look at it?
Flags: needinfo?(bugs)
(In reply to Geoff Brown [:gbrown] from comment #3)
> I'll try to narrow the regression range:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-
> searchStr=android%20reftest&tochange=2f9d2be88b3854db220c9f1696a40140a360c9a2
> &fromchange=739f1c4bee0df80fcf014af10a6c83eaccc80211

The earliest I could find was https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=2f9d2be88b3854db220c9f1696a40140a360c9a2&filter-searchStr=android+reftest, but the failure was so infrequent on that changeset, I would say it is unclear which changeset is responsible.
Flags: needinfo?(gbrown)
:jet, any chance we can get some attention to this bug?  

:ni myself to follow up on Tuesday if needed.
Flags: needinfo?(jmaher)
Maybe similar to bug 1342240, though this test doesn't seem to be the first test in the run.  Is it the first test in the run with a checked checkbox in it?
See Also: → 1342240
Seems like a decent chance this is a regression from either bug 605985 or bug 1338293.
Flags: needinfo?(mats)
The test is doing "el.checked = true" in the callback.  Since the check-mark is an image
on Android it seems there is a race between loading it and the 'transitionend' event that
removes the 'class' attribute, which triggers the reftest screenshot.
http://searchfox.org/mozilla-central/source/layout/reftests/webcomponents/input-transition-1.html

I think we just need to wait for it to load somehow.

It's a bit mysterious why this turns up now though...
Does radio/checkbox elements have additional style sheets on Android besides forms.css?
Flags: needinfo?(mats)
thanks :dbaron and :mats for chiming in here.

:snorp, do you know the answer to :mats question in comment 11?
Flags: needinfo?(jmaher) → needinfo?(snorp)
Whiteboard: [stockwell needswork]
I'm not an expert on these bits, but there is some css for forms in https://dxr.mozilla.org/mozilla-central/source/mobile/android/themes/core/content.css
Flags: needinfo?(snorp)
This has been failing at 50+ times/week for the last few weeks, I want to disable this test, ni? myself to write a patch for that later today.
Flags: needinfo?(jmaher)
Attached patch wallpaperSplinter Review
Waiting 1 second before taking the reftest snapshot seems to cure it.
It's a bit ugly, but think I'd prefer that over disabling the test.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c9a3fd396a48f2a6dbd1d7dec337308f8b75839c
Attachment #8847113 - Flags: feedback?(jmaher)
that seems reasonable- if we do that, we should consider leaving this bug open or filing a follow up to investigate the issues.
Flags: needinfo?(jmaher)
Comment on attachment 8847113 [details] [diff] [review]
wallpaper

Review of attachment 8847113 [details] [diff] [review]:
-----------------------------------------------------------------

this is really hacky, but it will help ensure we are avoiding timing issues.
Attachment #8847113 - Flags: feedback?(jmaher) → feedback+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/efbc8ac7bca1
Wallpaper an orange failure by delaying the snapshot for 1s. r=me
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/efbc8ac7bca1
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Whiteboard: [stockwell needswork] → [stockwell fixed]
Flags: needinfo?(bugs)
You need to log in before you can comment on or make changes to this bug.