Closed Bug 133909 Opened 18 years ago Closed 18 years ago

Setting "default browser" in installation goes too far

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 131106

People

(Reporter: 3.14, Assigned: law)

Details

I guess this is an all-windows-bug.

Problem: When installing Mozilla, the installer ask if it should set as a
default browser. If you do so, it not only does that, but also makes itself
default viewer for pictures.

It does that even when the previously installed (and then uninstalled) version
was configured to leave pictures alone.

There seems to be no way to stop that, but to not make it the dafault browser
and change the settings later by hand.

Expected behavior: When asking to make Mozilla the default *browser*, it should
do exactly that and not claim diffent file type (i.e., all images, possibly
more) which are already taken by other programs without asking.

pi
not installer...
Assignee: dveditz → law
Component: Installer → File Handling
QA Contact: bugzilla → sairuh
Yes, I think you should check boxes separately like in the Preferences /
Advanced / System ,  as it happens during the installation of Netscape 4.x
Check my recommended procedure for upgrading Mozilla on Win98 in bug 133476
Comment #7 as a workaround.
Wouldn't this be bug 131106 ?

*** This bug has been marked as a duplicate of 131106 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
ACK

pi
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.