reference parent proxy by id

RESOLVED FIXED in Firefox 53

Status

()

Core
Disability Access APIs
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: tbsaunde, Assigned: tbsaunde)

Tracking

unspecified
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 wontfix, firefox53 fixed, firefox54 fixed)

Details

(Whiteboard: aes+)

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

9 months ago
Created attachment 8836775 [details] [diff] [review]
reference parent proxy by id
Attachment #8836775 - Flags: review?(eitan)
Comment on attachment 8836775 [details] [diff] [review]
reference parent proxy by id

Review of attachment 8836775 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #8836775 - Flags: review?(eitan) → review+

Comment 3

9 months ago
Pushed by tsaunders@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/62f820d36c91
reference parent proxy by id r=eeejay

Comment 4

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/62f820d36c91
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54

Updated

9 months ago
Blocks: 1336770
Blocks: 1339168

Updated

9 months ago
Whiteboard: aes+
Do we want to uplift this to Aurora since we know it fixed some crashes?
Assignee: nobody → tbsaunde+mozbugs
status-firefox53: --- → affected
Flags: needinfo?(tbsaunde+mozbugs)
(Assignee)

Comment 6

9 months ago
Comment on attachment 8836775 [details] [diff] [review]
reference parent proxy by id

Approval Request Comment
[Feature/Bug causing the regression]:unknown e10s and a11y related
[User impact if declined]:crashes
[Is this code covered by automated tests?]:yes, though none of them found the issues this fixes.
[Has the fix been verified in Nightly?]:yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:low
[Why is the change risky/not risky?]:fairly straight forward change.
[String changes made/needed]:none
Flags: needinfo?(tbsaunde+mozbugs)
Attachment #8836775 - Flags: approval-mozilla-beta?
Attachment #8836775 - Flags: approval-mozilla-aurora?

Updated

9 months ago
status-firefox52: --- → affected

Comment 7

9 months ago
Comment on attachment 8836775 [details] [diff] [review]
reference parent proxy by id

Fix possible crash. Aurora53+.
Attachment #8836775 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 8

9 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/a6d3ee554e58
status-firefox53: affected → fixed
Comment on attachment 8836775 [details] [diff] [review]
reference parent proxy by id

AIUI this only affects people who force-enable e10s on 52?  a- on that basis, as we're late in the cycle and I don't know if we'd have time to fix any fallout.
Attachment #8836775 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
status-firefox52: affected → wontfix
You need to log in before you can comment on or make changes to this bug.