Undoing 'Close All Tabs' focuses first tab in tray and not last opened tab

RESOLVED WONTFIX

Status

()

Firefox for iOS
General
P3
normal
RESOLVED WONTFIX
11 months ago
7 months ago

People

(Reporter: Adrian Oniga, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios9.0, fxios-v7.0 affected)

Details

(Whiteboard: [MobileCore])

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

1. Open three tabs(sportsdirect.com, bbc.com, amazon.com)
2. Tap the counter button from the top right corner
3. Open tab tray menu, tap "Close all tabs"
4. After the tabs are closed tap "Undo"   



Actual results:

1. 3 Tabs are opened
2. Tabs are displayed with the tabs tray menu at the bottom of the page
3. All tabs are closed
4. Tabs are restored but the last visited opened tab is not opened. The first tab in tray is opened instead 


Expected results:

4. Tabs are restored and the last visited tab is opened
(Reporter)

Comment 1

11 months ago
Found on iPhone 6, iOS 10.2.1, Firefox 7.0(1), buddybuid #1524

-In private browsing step 4 performs as expected and the last visited tab is opened in the browser.

Comment 2

11 months ago
This issue also occurs on the latest master. 

For consistency, we should probably have the same behaviour for both private and normal browsing.
Status: UNCONFIRMED → NEW
status-fxios-v7.0: --- → affected
tracking-fxios: --- → ?
Ever confirmed: true

Updated

11 months ago
tracking-fxios: ? → 8.0+
Priority: -- → P3
Whiteboard: [MobileCore]

Updated

10 months ago
Duplicate of this bug: 1346935

Updated

8 months ago
tracking-fxios: 8.0+ → 9.0

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.