Mozilla supports only 16-color icon in URL bar

VERIFIED DUPLICATE of bug 109214

Status

()

Core
ImageLib
VERIFIED DUPLICATE of bug 109214
17 years ago
17 years ago

People

(Reporter: Michal Horák, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
In the page at http://mobiljuice.lovcipokladu.cz/web/ you can see green anchor
icon  in URL bar. The icon (standard .ICO format with 16 and 256 color version)
is displayed only in 16 colors. In IE you must add the page to favorites, then
you can see the right, 256 colored, antialiased icon.
hm. right now our .ico decoder code looks for the first icon in the file that
has the dimensions 16x16 (if none is found, the last icon is used).

it should indeed use the icon with the highest color depth, but I think that bug
is already filed. hm, looks like a dup of bug 109214... though the summary of
that one isn't clear. marking as dup.

changing component.

*** This bug has been marked as a duplicate of 109214 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: URL Bar → ImageLib
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
> our .ico decoder code looks for the first icon in the file

The .ICO file was saved in Microangelo Studio 5.0 - maybe this is the problem?
no, the real problem is in Mozilla's icon display code. It doesn't display the
icon with the highest color depth, but the first one it can find.
You need to log in before you can comment on or make changes to this bug.