Meeting Cancellation Sent By Non-Organizer

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: jdhood1, Unassigned)

Tracking

Lightning 4.7.4

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170201180315

Steps to reproduce:

I deleted a meeting on my calendar that was organized by somebody else.


Actual results:

A meeting cancellation notice was sent to everybody on the meeting invitation.


Expected results:

Only a decline notice should have been sent to the meeting organizer.  Nobody else on the meeting should have been affected.  I was NOT the organizer.

Updated

2 years ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 45 Branch → Lightning 4.7.7

Comment 1

2 years ago
What exact Lightning version are you on (look at the TB addon manager to get the information)?

Can you please describe your account/identity/calendar setup in detail?

Please answer also the following additional questions:
Are you also managing the calendar of the organizer of that event within Lightning?
Do you have associated the email identity you received the invitation for to a calendar managed in Lightning (see the calendar's propoerties in the calendar list of the calendar view)?
Are you storing sent and received emails in the same folder for the respective account you received the invitation in?
Component: General → E-mail based Scheduling (iTIP/iMIP)
(Reporter)

Comment 2

2 years ago
Of course.  I'm happy to help any way I can.

Thunderbird version is 45.7.0
Lightning version is 4.7.4

My configuration is a little goofy because of the restrictions my company puts on the Microsoft mail server.  They only have Exchange enabled, no POP3, IMAP, etc.  So, I am running DavMail to connect to the Outlook Web App (OWA) HTTP location.  It then translates to POP3, IMAP, etc. for Thunderbird.  I then have Thunderbird connected to localhost (DavMail).  I tried "Provider for Microsoft Exchange", but I didn't know the Exchange host to use.  "ExQuilla for Microsoft Exchange" auto-discovered a server and worked, but was really slow (on the order of taking an hour to download 100 e-mails).  So, I've been using DavMail since.

The calendar protocol in DavMail is called CalDAV (http://localhost:1080/users/user_name@host.com/calendar).  That's what Lightning uses to get the calendar.  I also applied the tweaks recommended by the "Calendar Tweaks" (v.6.3) plugin.

Here are the answers to your specific questions:

Are you also managing the calendar of the organizer of that event within Lightning?
No.  I didn't even know the person until I had to confess that I had cancelled her meeting and that the cancelation had gone out to over 1000 people!  :-)

Do you have associated the email identity you received the invitation for to a calendar managed in Lightning (see the calendar's propoerties in the calendar list of the calendar view)?
Yes, I believe so.  When I open the calendar properties, the "E-Mail" field has my e-mail address in it.  It looks like the options are my e-mail address or "None".  I assume that is how it sends the organizer an e-mail when I accept or decline meetings.

Are you storing sent and received emails in the same folder for the respective account you received the invitation in?
I think so.  I checked the box that says to keep sent e-mails in the same folder as the e-mail I'm replying to.  However, when I send a new e-mail, it goes to the "Sent" folder.

Please let me know if what I'm saying doesn't make sense or if you have more questions.  Thank you for looking into this.
Version: Lightning 4.7.7 → Lightning 4.7.4

Comment 3

2 years ago
Is the event still in your caldav calendar or was it removed when replying? If it still exists, please attach it to this bug.

Also, can you attach the originally received invitation email and the sent out reply to this bug?

You can modify sensitive information within the email or the ics for privacy reasons, but please don't change the information structure of these.

Additionally, as you seem to have access to the davmail installation, do you still have the davmail logfile available which was written when receiving the invitation and sending out the reply and conatins any details to the conversion? If so, can you please attach that as well?
Flags: needinfo?(jdhood1)
(Reporter)

Comment 4

2 years ago
It was removed from my calendar.  Sorry.
I also searched everywhere for the original invitation, but cannot find it.
The DavMail logs for that time are not interesting:

2017-02-10 09:23:58,646 DEBUG [main] davmail  - OS Name: Linux Java version: 1.8.0_121 64 System tray supported Current Desktop: Unity
2017-02-10 09:23:58,654 INFO  [main] davmail  - Detected Unity desktop, please follow instructions at http://davmail.sourceforge.net/linuxsetup.html t
2017-02-10 09:23:59,172 INFO  [main] davmail  - DavMail Gateway 4.7.3-2438 listening on SMTP port 1025 POP port 1110 IMAP port 1143 CALDAV port 1080 L
2017-02-10 09:23:59,373 DEBUG [CheckRelease] davmail.DavGateway  - DavMail released version: 4.7.3-2438
2017-03-06 08:19:43,072 DEBUG [main] davmail  - OS Name: Linux Java version: 1.8.0_121 64 System tray supported Current Desktop: Unity
2017-03-06 08:19:43,166 INFO  [main] davmail  - Detected Unity desktop, please follow instructions at http://davmail.sourceforge.net/linuxsetup.html t
2017-03-06 08:19:48,436 INFO  [main] davmail  - DavMail Gateway 4.7.3-2438 listening on SMTP port 1025 POP port 1110 IMAP port 1143 CALDAV port 1080 L
2017-03-06 08:19:49,234 DEBUG [CheckRelease] davmail.DavGateway  - DavMail released version: 4.7.3-2438

I'll reply again with more.
(Reporter)

Comment 5

2 years ago
The only thing I could find from the original transaction was the cancellation message Thunderbird sent to everyone.  I've pasting the message source below.  I did not see anything below that seemed super sensitive, but please update this post if you see anything.  I don't want to get in trouble with my company.

From: Jeremy Hood <jeremy.hood@ericsson.com>
Message-ID: <cfc2cffe-fc41-b98b-a998-15f521b1c3d1@ericsson.com>
To: Ericsson TV & Media Readiness <PDLSSONTVM@pdl.internal.ericsson.com>,
	George Golfinopoulos <george.golfinopoulos@ericsson.com>
Date: Tue, 14 Feb 2017 07:57:07 -0500
Subject: Event Canceled: MF Tech Training for TSS and FE: UX
 Extensibility & Customization Framework
Content-Class: urn:content-classes:calendarmessage
Content-Type: text/calendar; method=CANCEL; charset="UTF-8"
Content-Transfer-Encoding: 8BIT
MIME-Version: 1.0

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
METHOD:CANCEL
BEGIN:VTIMEZONE
TZID:America/New_York
BEGIN:DAYLIGHT
TZOFFSETFROM:-0500
TZOFFSETTO:-0400
TZNAME:EDT
DTSTART:19700308T020000
RRULE:FREQ=YEARLY;BYDAY=2SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0400
TZOFFSETTO:-0500
TZNAME:EST
DTSTART:19701101T020000
RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=11
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20170213T161455Z
LAST-MODIFIED:20170202T195540Z
DTSTAMP:20170202T195540Z
UID:040000008200E00074C5B7101A82E00800000000A0577F12B87BD20100000000000000
 00100000002956419B9721DC47ABE9A70349DCA2A6
SUMMARY:MF Tech Training for TSS and FE: UX Extensibility & Customization 
 Framework
PRIORITY:5
STATUS:CONFIRMED
ORGANIZER;CN=Jamie Kaushik;SENT-BY="MAILTO:jeremy.hood@ericsson.com":mailt
 o:jamie.kaushik@ericsson.com
ATTENDEE;CN=Ericsson TV & Media Readiness;PARTSTAT=NEEDS-ACTION;ROLE=REQ-P
 ARTICIPANT:mailto:PDLSSONTVM@pdl.internal.ericsson.com
ATTENDEE;CN=George Golfinopoulos;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPAN
 T:mailto:george.golfinopoulos@ericsson.com
DTSTART;TZID=America/New_York:20170215T113000
DTEND;TZID=America/New_York:20170215T130000
CLASS:PUBLIC
DESCRIPTION:\n\n\n\n[cid:image001.png@01D1F872.40808620]<http://www.ericss
 on.com/>\n\n\n[cid:image002.png@01D1F872.40808620]\n\n\n\n\n\n\n\n\n\n\n\n
 \n[cid:image009.jpg@01D271D5.C9A14D90]\n\n\n\nMediaFirst TV Platform UX Ex
 tensibility and Customization Framework\n\nAttend this webinar to learn ab
 out:\n\nUX and Platform Goals\n\nMF Client\, web app and shells\n\nDevice 
 coverage and lifecycle process\n\n?         Options to expand and extend\n
 \nCustomizations\n\n?         Overview\n\n?         Options for Hubs and F
 eeds\n\n?         Skinning: UX tools\, version manager\, stores-in-store\n
 \n?         SDK for building Apps\n\n?         Demos\n\n?         Roadmap\
 n\nNote\, this webinar is part of a series of upcoming sessions.  Keep you
 r eye out for invitations covering the following topics:\n\nFeb-22   MF AB
 R AV Pipe\n\nMar-1     MF Operations\n\nMar-8     Private Cloud deployment
 s\n\n[cid:image004.png@01D1F872.40808620]\n\n\nPresenter\n\n?         Howa
 rd Cooperstein\n\n\nIn case of questions\, please contact us<mailto:tvglob
 altraining@ericsson.com?subject=I%20have%20a%20question...>.\n\n\n\n\n[cid
 :image005.png@01D1F872.40808620]\n\nDate\nWednesday\, February 15\, 2016\n
 \nDuration\n90  mins\nAudience\nThis is intended for TSS and SA?s working 
 in BU Media and anyone else looking for an understanding of the MediaFirst
  Solution.\nWebinar\nTo enhance your webinar experience we use Adobe Conne
 ct for hosting all webinars. You can join using your PC or laptop by click
 ing on the JOIN WEBINAR link in the meeting invitation. For convenience yo
 u can also download iOS and/or Android Connect clients to join while mobil
 e.\nJoin Webinar<https://ericsson.acms.com/bmdaservices1/>\nAdobe Connect 
 for iOS<https://itunes.apple.com/us/app/adobe-connect-mobile-for-ios/id430
 437503?mt=8>\nAdobe Connect for Android<https://play.google.com/store/apps
 /details?id=air.com.adobe.connectpro>\nWebinar will be recorded and availa
 ble for\non-demand viewing.\n\n\n\nTV Academy ~ Learn Anytime\n\nBuild up 
 your sales and technical skills with over 200 courses on TV Academy<https:
 //ericoll.internal.ericsson.com/sites/Ericsson_Academy_TV_and_Media_Manage
 ment/default.aspx>.\n\n[cid:image006.jpg@01D1F922.C4BD7550]<https://ericol
 l.internal.ericsson.com/sites/Ericsson_Academy_TV_and_Media_Management/def
 ault.aspx>\n\nTV & Media Demos\n\nCurrent TV & Media product demonstration
  tools are always available on http://apps.ericsson.net/ and we will be up
 dating the site with the latest IBC 2016 demos\, as available for field us
 e\, during September.\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n[cid:im
 age006.png@01D1F872.40808620]<http://www.ericsson.com/>\n\n\n\n\n\n\n\n\n
 
TRANSP:OPAQUE
SEQUENCE:1
LOCATION:Adobe Connect
X-MICROSOFT-CDO-APPT-SEQUENCE:1
X-MICROSOFT-CDO-OWNERAPPTID:-188803103
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-DISALLOW-COUNTER:TRUE
END:VEVENT
END:VCALENDAR
(Reporter)

Comment 6

2 years ago
I tried to reproduce this problem with a couple of friends here at work, but could not.  I went to one friend and had him send an invitation to me and someone else.  I then deleted the request from my calendar.  It sent the meeting organizer a decline note, as I would expect it to.  The other person did not see anything from me.  This is exactly the behavior I would expect.

Thinking back on this, I was trying DavMail and a few plug-ins offered for Thunderbird to see which worked best for communicating with an Exchange server.  One of the plug-ins I used was "ExQuilla for Microsoft Exchange".  I also tried "Provider for Microsoft Exchange", but could not figure out the proper server to set.  ExQuilla, though, I think has an option to automatically add meetings to my calendar.  I think ExQuilla may have saved the meeting to my calendar.  Then, when I deleted it, I was probably using the DavMail interface, since I couldn't get Provider for Microsoft Exchange to work.  Could it be that the DavMail interface thought I was the organizer because ExQuilla added it to my calendar in a different way?  Perhaps ExQuilla added it as if I were the organizer.

I do know that the meeting was automatically added to my calendar.  I did not accept it.
I recently read that ExQuilla does not implement calendaring, so it may be a good idea to use the Provider for MS Exchange. It looks like you have quite a mix of add-ons and server settings that may be in conflict with each other.

The meeting may have been added to the calendar by the server too if that has not already been mentioned. Given you cannot reproduce I'm going to close this bug, feel free to comment if you are able to figure out more details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Flags: needinfo?(jdhood1)
You need to log in before you can comment on or make changes to this bug.