mach errors when trying to build and compile for the first time

NEW
Unassigned

Status

()

2 years ago
2 years ago

People

(Reporter: Epransky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Followed the quickstart instructions here: https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_Firefox_for_Android_build

Everything was fine until I tried running the mach commands. Nothing seems to be working correctly. I have src/mozilla-central and a mozconfig file in mozilla-central with the following contents:
# Build Firefox for Android:
ac_add_options --enable-application=mobile/android
ac_add_options --target=arm-linux-androideabi

# With the following Android SDK and NDK:
ac_add_options --with-android-sdk="/home/epranskee/.mozbuild/android-sdk-linux"
ac_add_options --with-android-ndk="/home/epranskee/.mozbuild/android-ndk-r11b"

When I run mach build from the mozilla-central dir, it runs a bunch of things but always ends with
 checking for rustc... not found
 0:03.00 checking for cargo... not found
 0:03.00 ERROR: Rust compiler not found.
 0:03.00 To compile rust language sources, you must have 'rustc' in your path.
 0:03.00 See https//www.rust-lang.org/ for more information.
 0:03.00 
 0:03.00 You can install rust by running './mach bootstrap'
 0:03.00 or by directly running the installer from https://rustup.rs/
 0:03.00 
 0:03.03 *** Fix above errors and then restart with\
 0:03.03                "/usr/bin/make -f client.mk build"
 0:03.03 client.mk:379: recipe for target 'configure' failed
 0:03.03 make: *** [configure] Error 1

When I run mach package, I get
 0:00.13 /usr/bin/make -C . -j8 -s -w package
 0:00.13 make: Entering directory '/path/to/src/mozilla-central/obj-arm-linux-androideabi'
 0:00.13 make: *** No rule to make target 'package'.  Stop.
 0:00.13 make: Leaving directory '/path/to/src/mozilla-central/obj-arm-linux-androideabi'
You need to log in before you can comment on or make changes to this bug.