Update Client interface to remove frameType, add ancestorOrigins and type

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

2 years ago
In order to make sure I'm propagating the right information across the IPC boundary I want to update our Client implementation to the current spec first.  This basically means:

1) Remove Client.frameType
2) Add Client.ancestorOrigins
3) Add Client.type
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1290936
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1264180
(Assignee)

Comment 3

2 years ago
The Client.reserved attribute will have to wait for the changes in 1293277.  I could implement it returning always false, but then people could not feature detect reserved clients with `'reserved' in Client`.
(Assignee)

Comment 4

2 years ago
Created attachment 8837340 [details] [diff] [review]
P1 Update Client webidl, remove FrameType code, and implement c++ stubs. r=asuth
Keywords: dev-doc-needed
(Assignee)

Comment 5

2 years ago
Actually, I'm going to move this work back to the individual bugs.  We can't just blanket update all of this stuff for different reasons.
No longer blocks: 1226983, 1293277
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: dev-doc-needed
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Attachment #8837340 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.