Crash in nsAString_internal::Assign | nsAString_internal::Assign | nsString::operator=

RESOLVED FIXED in Firefox 54

Status

()

--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: dvander)

Tracking

({crash})

Trunk
mozilla54
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 fixed)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-3eb6a41d-8a40-4b7c-b515-a51fa2170214.
=============================================================

Seen while looking at crash stats - new crash which started using 20170214030231 build: http://bit.ly/2l5CVfo

Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00d16f03506b7f9f754b01a0a458c05445ac6dba&tochange=195049fabb7ac5709e5f75614ba630ba3d1b5a9b

Possibly related to Bug 1337518? ni on dvander since I see ipc/glue/CrashReporterHost.cpp:71 in the crash source.
Flags: needinfo?(dvander)
This is indeed bug 1337518. It's fixed by bug 1339603, which is waiting on review. If Bill can't get to that in a day or two I'll do a spot fix here.
Assignee: nobody → dvander
Blocks: 1337518
Status: NEW → ASSIGNED
Flags: needinfo?(dvander)
Component: Audio/Video: GMP → Graphics
Duplicate of this bug: 1340258
Should be fixed by bug 1338281.
Component: Graphics → IPC
Crash Signature: [@ nsAString_internal::Assign | nsAString_internal::Assign | nsString::operator=] → [@ nsAString_internal::Assign | nsAString_internal::Assign | nsString::operator=] [@ nsAString_internal::Assign | nsAString_internal::Assign | nsAutoString::operator=]
[@ nsAString_internal::Assign | mozilla::ipc::CrashReporterHost::GenerateCrashReport ] Looks like another variant of this crash.
Crash Signature: [@ nsAString_internal::Assign | nsAString_internal::Assign | nsString::operator=] [@ nsAString_internal::Assign | nsAString_internal::Assign | nsAutoString::operator=] → [@ nsAString_internal::Assign | nsAString_internal::Assign | nsString::operator=] [@ nsAString_internal::Assign | nsAString_internal::Assign | nsAutoString::operator=] [@ nsAString_internal::Assign | mozilla::ipc::CrashReporterHost::GenerateCrashReport ]
Should be fixed by bug 1338281.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: affected → fixed
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.