[ur] Update the search plug-ins for Fennec in Urdu

RESOLVED DUPLICATE of bug 1224261

Status

RESOLVED DUPLICATE of bug 1224261
2 years ago
2 years ago

People

(Reporter: delphine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We want to ship Firefox Mobile with a good list of search engines for Urdu.

We're going to work towards this in three phases. First, the localization team and the l10n drivers will look at the market for the language and come up with a good set of search providers. 

Khaled, Safa: we'll need your input on this, the guidelines for making recommendations are on <https://wiki.mozilla.org/L10n:Mobile/Productization>. 

For en-US, we currently use this set, to which we can fall back in the case of lacking localized alternatives:

> Google, Yahoo, Bing, Amazon, Twitter, Wikipedia

We may also want to go with just a subset of the en-US engines, if that's more appropriate for the local market.

Once we decide to use a particular search engine (and we test it on a mobile device), l10n drivers will contact the owner and ask for permission, and for specifics like proper search flags. 
Khaled, Safa: we'll likely need your help to at least get the contact information.

For search engines that we already ship with on desktop and that you would like to include in mobile as well, the permission is not needed.  Consider using a mobile version of the engine if one is available. For Android we'll want a specific 96x96px image, with colored background and rounder corners (6px radius).

Once we have a specification on what the search engines for  should look like, Delphine and the localization team will work on the implementation. Delphine will create and attach patches for the desired changes and get them reviewed. After a successful review, Delphine will land them. , if you're interested, you could create the patches, too. You'd ask Delphine for review on those before landing. 

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by Delphine, flod, Axel or someone else appointed by the l10n drivers. The data here is sensitive to users and our search partners, thus the extra care here.

The  team and Delphine will be driving this bug to completion.
Actually, it seems that the current list is pretty complete, by looking at https://hg.mozilla.org/releases/l10n/mozilla-aurora/ur/file/tip/mobile/searchplugins

Mohammad, Umer: can you please check with your team and see if there are any updates needed to these, or if we are already good to go? thank you :)
Flags: needinfo?(um.qshi)
Flags: needinfo?(myaseen.khan)
Thanks Delphine for filing a bug. I guess we are already done with setting up search engines. Can you please look out for this bug 1224261. Also please let me know if there is any confusion.
Flags: needinfo?(um.qshi)
Flags: needinfo?(myaseen.khan)
Youhou, that's one less thing to do then :D thanks for catching that
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224261
You need to log in before you can comment on or make changes to this bug.