TEST-UNEXPECTED-TIMEOUT | toolkit/components/telemetry/tests/unit/test_PingSender.js - Port bug 1310703 to C-C [Introduce the pingsender executable]

RESOLVED FIXED in Thunderbird 54.0

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jorgk, Assigned: Paenglab)

Tracking

({intermittent-failure})

Trunk
Thunderbird 54.0
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Thunderbird-testfailure: X all])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
First seen Tue Feb 14, 2017, 23:43:23:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=a7db0899f6a4eb581aca3e63668823a416111503

Looks like this is coming from bug 1310703.
https://hg.mozilla.org/mozilla-central/rev/ca283ec01ae1

Oh, perhaps it's as easy as adding this:

+@RESPATH@/crashreporter.ini
 
+; [ Ping Sender ]
+;
+@BINPATH@/pingsender@BIN_SUFFIX@
+

to package-manifest.in. I'll try that.
(Reporter)

Comment 1

2 years ago
Created attachment 8837456 [details] [diff] [review]
1339712-ping-sender.patch

Let's try this:

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=9c3716d6d9bfbb52220929769598a582e11f1206
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1339736
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1339736
(Reporter)

Comment 4

2 years ago
Richard, would you mind taking this on. Can we fix SM and IM at the same time?

My patch wasn't any good here, the try run said:
Error: package-manifest:652: Missing file(s): +bin/pingsender
Assignee: jorgk → richard.marti
(Reporter)

Updated

2 years ago
Attachment #8837456 - Attachment is obsolete: true
(Reporter)

Updated

2 years ago
Summary: TEST-UNEXPECTED-TIMEOUT | toolkit/components/telemetry/tests/unit/test_PingSender.js → TEST-UNEXPECTED-TIMEOUT | toolkit/components/telemetry/tests/unit/test_PingSender.js - Port bug 1310703 to TB [Introduce the pingsender executable]
(Assignee)

Comment 5

2 years ago
Created attachment 8837484 [details] [diff] [review]
Pingsender.patch

app/macbuild/Contents/MacOS-files.in and installer/windows/nsis/shared.nsh needed also changes.
Attachment #8837484 - Flags: review?(jorgk)
(Reporter)

Comment 6

2 years ago
Thanks, Richard. Sorry about my poor quality patch. So for Linux there is no file that needs to change for the installer? Or maybe the distros do that. BTW, sorry about bug 1336804 whose patch is now most likely rotten.

I think this needs a try run to see whether it fixes the test failure:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=52b20190dc85c5f1d5832c625312aad6dd0c0acb
Summary: TEST-UNEXPECTED-TIMEOUT | toolkit/components/telemetry/tests/unit/test_PingSender.js - Port bug 1310703 to TB [Introduce the pingsender executable] → TEST-UNEXPECTED-TIMEOUT | toolkit/components/telemetry/tests/unit/test_PingSender.js - Port bug 1310703 to C-C [Introduce the pingsender executable]
(Assignee)

Comment 7

2 years ago
Bug 1336804 isn't rotten. :-)
(Assignee)

Comment 8

2 years ago
https://hg.mozilla.org/comm-central/rev/0dd78c1841a9e0f5a797a95dfa7383869eee504e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 54.0
(Reporter)

Comment 9

2 years ago
Comment on attachment 8837484 [details] [diff] [review]
Pingsender.patch

Thanks!
Attachment #8837484 - Flags: review?(jorgk) → review+
This currently breaks my local suite compile. I think its only compiled when telemetry is on which SeaMonkey doesn't do. Need to investigate.
Posted too soon. Might just have needed a configure. Compile running.
You need to log in before you can comment on or make changes to this bug.