Closed Bug 1339715 Opened 3 years ago Closed 3 years ago

Do per screen HiDPI scaling in Windows 10

Categories

(Thunderbird :: OS Integration, defect)

45 Branch
Unspecified
Windows 10
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1255475

People

(Reporter: martin, Unassigned)

Details

(Keywords: dpi)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

1. Attach 2 screens with different scaling to a Windows 10 machine. (e.g. one HiDPI and one Non-HiDPI)
2. Drag Thunderbird from the primary screen to the secondary screen.


Actual results:

Thunderbird does not adjust it's scaling to the secondary screen. Instead the OS recognizes this and does a simple scaling of the already painted window, which looks really bad.


Expected results:

Thunderbird should recognize the changed scaling and adjust automatically.
Keywords: dpi
OS: Unspecified → Windows 10
Hi, please test if the issue can still be reproduced with the latest beta. You find it at https://www.mozilla.org/en-US/thunderbird/channel/
Some bugs about similar issues got fixed in the meantime, e.g. bug 1255475.
Flags: needinfo?(martin)
Yes! Fixed in the Beta! Sorry, in the future I will try this first before filing a bug.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(martin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255475
You need to log in before you can comment on or make changes to this bug.