xlink:href attribute of <animate> element is not honored when linked by <use> element

RESOLVED DUPLICATE of bug 738574

Status

()

defect
RESOLVED DUPLICATE of bug 738574
2 years ago
2 years ago

People

(Reporter: tristan.fraipont, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

635 bytes, image/svg+xml
Details
232 bytes, text/html
Details
Reporter

Description

2 years ago
Posted file animateBug.zip (obsolete) —
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170213070939

Steps to reproduce:

When we set a <use> element to target a group of elements contained in an external File, and that one of these elements is an <animate> which TargetElement has been defined through the xlink:href attribute, then the TargetElement is not found (animate doesn't work).
When the TargetElement is set implicitly, because <animate> is a child of the target, then it works fine.

Live demo : http://plnkr.co/edit/n4kSVYt9cL2ygruecZfn?p=preview
Reporter

Comment 1

2 years ago
Posted file animateBug.html (obsolete) —
Attachment #8837581 - Attachment is obsolete: true
Reporter

Comment 2

2 years ago
Posted image spinner_1.svg
target svg
Reporter

Comment 3

2 years ago
Posted file animateBug.html
Fixes link so it works in bugzilla
Attachment #8837595 - Attachment is obsolete: true
Perhaps, gecko can't animate with xlink:href attribute now.

simple test case:
https://people-mozilla.org/~myoshinaga/svg/bug1339788/testcase.html

We can animate without xlink:href attribute. (The blue box of above testcase)
If we use xlink:href attribute to animate tag, we can't animate which cloned by using use tag.( The red box of above testcase)

The specification of animate tag, it allows xlink:href attribute. [1] So we will need to allow this behavior. Other User Agents is allowed this behavior. (Chrome / Safari)

[1] https://www.w3.org/TR/SVG11/animate.html#AnimateElement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738574
You need to log in before you can comment on or make changes to this bug.