browsingData.settings() does not work if "Time range to clear" is set to "Everything"

RESOLVED DUPLICATE of bug 1339868

Status

RESOLVED DUPLICATE of bug 1339868
2 years ago
2 months ago

People

(Reporter: wbamberg, Assigned: bsilverberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: investigate)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8837703 [details]
browsingData-settings.zip

I've attached a WebExtension that adds a browser action. When you click the icon it calls browsingData.settings and logs the result.

In Firefox Nightly (54.0a1) it works fine.

In Firefox Dev Edition (53.0a2) it does not work, and logs this error:

    Sanitizer.getClearRange(...) is null      ext-browsingData.js:190
(Assignee)

Updated

2 years ago
Assignee: nobody → bob.silverberg
Whiteboard: investigate
(Assignee)

Comment 1

2 years ago
I just tested it with Dev Edition (53.0a2 (2017-02-15) (64-bit)), and it works fine for me. I'm on OS X. What platform are you on? Also, can you test with a brand new profile?
Flags: needinfo?(wbamberg)
(Reporter)

Comment 2

2 years ago
OS X as well.

More information: I can reproduce this only when "Time range to clear" is set to "Everything".
Flags: needinfo?(wbamberg)
(Assignee)

Comment 3

2 years ago
Ah, I didn't try that. Also, that reproduces on Nightly as well, so it's not a 53 thing. I guess you only tested that on 53. Thanks for clarifying.
(Reporter)

Comment 4

2 years ago
Yes, indeed. I just saw it worked in Fx54 and not in 53, and didn't think to check this. I just updated the bug summary.
Summary: browsingData.settings() does not work in Firefox 53 → browsingData.settings() does not work if "Time range to clear" is set to "Everything"
(Assignee)

Comment 5

2 years ago
Thanks Will. Because this is also a very small bug in browsingData.settings, I am going to dupe it to bug 1339868 to make it easier to land and, potentially, uplift the fixes.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1339868

Updated

2 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.