[swift-3-regression] - Firefox share extension, 'Add to Bookmark/Reading List' not working

RESOLVED WORKSFORME

Status

()

Firefox for iOS
General
P1
normal
RESOLVED WORKSFORME
8 months ago
7 months ago

People

(Reporter: Adrian Oniga, Assigned: sleroux)

Tracking

({regression})

unspecified
Other
iOS
regression

Firefox Tracking Flags

(fxios7.0+)

Details

(Whiteboard: [MobileCore])

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

1. Open Firefox
2. Go to bbc.com
3. Open "Share" menu and tap on Firefox 
4. In the displayed pop-up tap on "Add to reading list" and "Add to bookmarks" options to select them
5. In the same pop-up tap on the "Add" button from the upper right corner
6. Go to "Bookmarks"
7. Go to "Reading list"


Actual results:

2  Bbc.com page is correctly opened
3. Share menu can be opened and Firefox button can be tapped. A pop-up with "Add to reading list" and "Add to bookmarks" is diplayed
4. "Add to reading list" and "Add to bookmarks" options can be selected
5. "Add" button from the upper right corner of the pop-up can be tapped and the pop-up closes
6. The page (bbc.com) is not added to "Bookmarks"
7. The page (bbc.com) is not added to "Reading list"



Expected results:

6. The page (bbc.com) should be added to "Bookmarks"
7. The page (bbc.com) should be added to "Reading list"
(Reporter)

Comment 1

8 months ago
Found on iPhone 6, iOS 10.2.1, Firefox version 7.0(1) buddybuild #1609
Sound's like a potential swift-3.0 migration regression. This works on 6.0. Thank's for the report.
Status: UNCONFIRMED → NEW
tracking-fxios: --- → ?
Ever confirmed: true
Keywords: regression
Summary: Add to bookmarks and to reading list → Firefox share extension, 'Add to Bookmark/Reading List' not working
Re-summarizing, just on a hunch
Summary: Firefox share extension, 'Add to Bookmark/Reading List' not working → [swift-3-regression] - Firefox share extension, 'Add to Bookmark/Reading List' not working
(Reporter)

Comment 4

8 months ago
Thanks Aaron! i can confirm this is working correctly on version 6.0 ( iPhone 6, iOS 10.2.1)
(Assignee)

Updated

8 months ago
tracking-fxios: ? → 7.0+
Whiteboard: [MobileCore]
(Assignee)

Comment 5

8 months ago
Moving to P1 since this is a regression/broken functionality.
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
Iteration: --- → 1.16
Priority: -- → P1
(Assignee)

Comment 6

8 months ago
Seems to work for me locally in Xcode. Let's give this a try when the next 7.0 beta comes out.

Updated

8 months ago
Iteration: 1.16 → 1.17
(Assignee)

Comment 7

8 months ago
I'm able to reproduce in 7.0b1986 - will investigate.
I cannot reproduce this issue in 7.0b2011. If someone else can, please reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.