If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

All downloads fail. Retry button in Downloads tab works in some cases. Possibly related to Android App Protection.

RESOLVED WORKSFORME

Status

()

Firefox for Android
Download Manager
RESOLVED WORKSFORME
7 months ago
7 months ago

People

(Reporter: smartfon.reddit, Unassigned)

Tracking

51 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170215030342

Steps to reproduce:

Installed Firefox for Android. Tested with Firefox Beta too. Downloaded any file with it. 


Actual results:

The download was interrupted. Download manager says it "Failed".


Expected results:

It should download the file. Firefox's Download manager should show the file without 'Failed" tag and Android's "Downloads" directory should have the file.
(Reporter)

Comment 1

7 months ago
1. Installed FX and/or FX Beta.
2. Open FX. Android App Protection (privacy thing that forces apps to ask permission before accessing things) shows an icon on notification bar that the app is protected.
3. Download any file. FX asks permission to modify files on the phone. Grant the permission. The download begins but the download icon (down arrow) on notification bar disappears immediately.
4. Open FX's Downloads manager, hold the failed item, press Retry and it fails again. Every time. Clearing cache and other items in Privacy area didn't help.
5. Open Android OS settings and disable App Protection for FX.
6. Return to FX and retry the download by holding the item and choosing Retry. It fails again.
7. Touch the download link on the website to download a new copy of the file, it fails again.
8. Open FX's Download manager. This time hold the NEWLY failed item and touch Retry. It downloads the item successfully. The file is visible in Android's Download path too.
9. From now on, every download fails just like before, but they can be downloaded successfully by touching them on FX's Download manager and choosing Retry.


Redmi Note 3 Pro running Android CM14.1. Happens with newly installed stable and Beta FX. Was also happening on FX50. Possibly on earlier versions too.
OS: Unspecified → Android
Hardware: Unspecified → ARM
(Reporter)

Comment 2

7 months ago
The Cyanogen feature in question is called "Privacy Guard". It was configured to protect all newly installed apps by default. 

Here are more updates:

1. I went and disabled Privacy Guard for newly installed apps.
2. Re-installed FX stable. At this point the Privacy Guard can't possibly interfere with FX.
3. Opened FX. No Privacy Guard icon on notification bar, which means it's not interfering with FX.
4. Initiated a file download.
5. FX asked for permission to access the phone. Permission granted.
6. Just like before, a 'Download started...' notification appeared and disappears on the bot
tom part of FX window. The download icon on notification bar disappeared immediately. The download failed.
7. Open FX Download Manager. Hold the failed file and "Retry". It fails again.
8. Went to website and initiated the download of the same file. It failed.
9. Went to FX Download Manager and Retried the NEW failed file. This time it was successful.
10. Downloaded a different file. It failed. Retrying it from Download Manager was successful.
11. From this point, every download fails but retrying them from Download Manager is successful.

It doesn't appear to be Android Privacy Guard related issue. Feel free to remove the last sentence in my bug title to avoid any confusion.

The phone has been rebooted many times.
tracking-fennec: --- → ?
(Reporter)

Comment 3

7 months ago
Must have been a problem with CyanogenMod ROM which is no longer being developed. The new ROM I installed is called LineageOS which is the same as Cyanogenmod but a different name and comes with latest bug fixes. There is no problem with Firefox Download manager on this new LingeageOS ROM. I guess the problem is solved. Feel free to delete/lock this thread.
Thanks for reporting back on your findings. Glad to hear an OS update resolved your problem.
Status: UNCONFIRMED → RESOLVED
tracking-fennec: ? → ---
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.