--without-intl-api builds broken by vTune patch

RESOLVED DUPLICATE of bug 1339190

Status

()

--
blocker
RESOLVED DUPLICATE of bug 1339190
2 years ago
2 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8837931 [details]
stack

# Full configuration command with needed environment variables is:
# AR=ar sh ./configure --enable-debug --enable-more-deterministic --without-intl-api --with-ccache --enable-gczeal --enable-debug-symbols --disable-tests

--without-intl-api builds seem to crash on startup.

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   https://hg.mozilla.org/mozilla-central/rev/aa1da5ed8a07
user:        Sean Stangl
date:        Tue Jan 17 14:35:42 2017 -0800
summary:     Bug 1332466 - Update VTune integration. r=sfink

Sean, is bug 1332466 a likely regressor?
Flags: needinfo?(sstangl)
Oh, good! I've been trying to reproduce this! This is Bug 1339190. Could I debug it on your computer tomorrow?

You can temporarily work around it by building with --disable-profiling.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sstangl)
Resolution: --- → DUPLICATE
Duplicate of bug: 1339190
You need to log in before you can comment on or make changes to this bug.