Static build fails on link stage

VERIFIED FIXED in mozilla1.0

Status

P1
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: mks, Assigned: netscape)

Tracking

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
A current checkout (10AM on 3/28/2002) fails to link in the static build but
does build and run correctly (for the most part) with the shared library build.
 (This is building on Linux - RedHat 7.2 based)

The .mozconfig file contains:

# sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#
# Options for 'configure' (same as command-line options).
ac_add_options --enable-crypto
ac_add_options --disable-debug
ac_add_options --enable-static
ac_add_options --disable-shared


The link error is:

nsStaticComponents.o: In function `JavaScript_Debugger_NSGetmodule':
nsStaticComponents.o(.text+0x22d): undefined reference to
`JavaScript_Debugger_gModuleInfo'
nsStaticComponents.o: In function `nsInspectorModule_NSGetmodule':
nsStaticComponents.o(.text+0x94d): undefined reference to
`nsInspectorModule_gModuleInfo'
collect2: ld returned 1 exit status
make[3]: *** [mozilla-bin] Error 1
make[3]: Leaving directory `/usr/src/mozilla/mozilla/xpfe/bootstrap'
make[2]: *** [tier_99] Error 2
make[2]: Leaving directory `/usr/src/mozilla/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/usr/src/mozilla/mozilla'
make: *** [build] Error 2

I have done:
    make -f client.mk clean ; make -f client.mk

If I change this shared rather than static, the build works.  I have repeated
this twice.
Fallout from bug 128507
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → mozilla1.0
Created attachment 76664 [details] [diff] [review]
Do not add jsd & inspector to the static link lists
Comment on attachment 76664 [details] [diff] [review]
Do not add jsd & inspector to the static link lists

sr=dveditz
Attachment #76664 - Flags: superreview+
For whatever it's worth, r=rjesup@wgate.com.  Looks good, straightforward.

Comment 5

17 years ago
*** Bug 134006 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Comment on attachment 76664 [details] [diff] [review]
Do not add jsd & inspector to the static link lists

i'm approving on behalf of drivers.
Attachment #76664 - Flags: approval+
Patch checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.