FileSystemDirectoryReader.readEntries bugs with accentuated characters

RESOLVED DUPLICATE of bug 1323935

Status

()

Firefox
Untriaged
--
major
RESOLVED DUPLICATE of bug 1323935
11 months ago
11 months ago

People

(Reporter: Loïc Bried, Unassigned)

Tracking

51 Branch
x86
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Happens on Windows 7, Firefox 51.0.1 32 bits (not tested with another version of Windows)
(I tested with the same Firefox version on Linux => no bug in this case)

Easy to reproduce : go on this page https://developer.mozilla.org/en-US/docs/Web/API/FileSystemDirectoryReader/readEntries
At the bottom of the page, there is a "Drop Files Here" zone.

Bug n°1 : In your file explorer, create a directory called "samplé" (e acute is important !) and containing a file called "foo.txt". Drag/drop the entire directory.

Bug n°2 : In your file explorer, create a directory called "sample" (no e acute here) and containing a file called "buggéd.txt" (e acute is important !). First step : drag/drop the file only. Second step : drag/drop the entire directory.




Actual results:

Bug n°1 : In the Directory tree, you only can read "samplé"

Bug n°2 : the first step is ok, you can read "buggéd.txt" in the Directory tree.
But on step 2, you read "buggéd.txt" in the Directory tree




Expected results:

Bug n°1 : you should read "samplé", and see the file "foo.txt" too

Bug n°2 : on the step 2, you should read "buggéd.txt"
(Reporter)

Updated

11 months ago
Severity: normal → major
OS: Unspecified → Windows
Hardware: Unspecified → x86

Comment 1

11 months ago
Fixed in 52+.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323935
You need to log in before you can comment on or make changes to this bug.