Crash in jemalloc_crash | arena_dalloc_small | je_free | `anonymous namespace''::wasapi_stream_stop

RESOLVED FIXED

Status

()

Core
Audio/Video: cubeb
P1
critical
Rank:
15
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: philipp, Assigned: padenot)

Tracking

({crash, regression})

51 Branch
All
Windows
crash, regression
Points:
---

Firefox Tracking Flags

(firefox51 wontfix, firefox52 wontfix, firefox-esr52 fixed, firefox53 fixed, firefox54 fixed)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-b39c41e6-e99d-460c-a053-6bd942170216.
=============================================================
Crashing Thread (101)
Frame 	Module 	Signature 	Source
0 	mozglue.dll 	jemalloc_crash 	memory/mozjemalloc/jemalloc.c:1631
1 	mozglue.dll 	arena_dalloc_small 	memory/mozjemalloc/jemalloc.c:4618
2 	mozglue.dll 	je_free 	memory/mozjemalloc/jemalloc.c:6485
3 	xul.dll 	`anonymous namespace'::wasapi_stream_stop 	media/libcubeb/src/cubeb_wasapi.cpp:1941
4 	xul.dll 	cubeb_stream_stop 	media/libcubeb/src/cubeb.c:291
5 	xul.dll 	mozilla::AudioStream::Shutdown() 	dom/media/AudioStream.cpp:467
6 	xul.dll 	mozilla::media::DecodedAudioDataSink::Shutdown() 	dom/media/mediasink/DecodedAudioDataSink.cpp:146
7 	xul.dll 	mozilla::media::AudioSinkWrapper::Stop() 	dom/media/mediasink/AudioSinkWrapper.cpp:214
8 	xul.dll 	mozilla::media::VideoSink::Stop() 	dom/media/mediasink/VideoSink.cpp:217
9 	xul.dll 	mozilla::MediaDecoderStateMachine::StopMediaSink() 	dom/media/MediaDecoderStateMachine.cpp:2476
10 	xul.dll 	mozilla::MediaDecoderStateMachine::SeekingState::Enter(mozilla::SeekJob, mozilla::MediaDecoderStateMachine::StateObject::EventVisibility) 	dom/media/MediaDecoderStateMachine.cpp:825
11 	xul.dll 	mozilla::MediaDecoderStateMachine::StateObject::SetState<mozilla::MediaDecoderStateMachine::SeekingState, mozilla::SeekJob, mozilla::MediaDecoderStateMachine::StateObject::EventVisibility>(mozilla::SeekJob, mozilla::MediaDecoderStateMachine::StateObject::EventVisibility) 	dom/media/MediaDecoderStateMachine.cpp:262
12 	xul.dll 	mozilla::MediaDecoderStateMachine::StateObject::HandleSeek(mozilla::SeekTarget) 	dom/media/MediaDecoderStateMachine.cpp:1157
13 	xul.dll 	mozilla::MediaDecoderStateMachine::Seek(mozilla::SeekTarget) 	dom/media/MediaDecoderStateMachine.cpp:2459
14 	xul.dll 	mozilla::detail::MethodCallInvokeHelper<RefPtr<mozilla::MozPromise<mozilla::MediaDecoder::SeekResolveValue, bool, 1> >, mozilla::MediaDecoderStateMachine, mozilla::SeekTarget, 0>(RefPtr<mozilla::MozPromise<mozilla::MediaDecoder::SeekResolveValue, bool, 1> > ( mozilla::MediaDecoderStateMachine::*)(mozilla::SeekTarget), mozilla::MediaDecoderStateMachine*, mozilla::Tuple<mozilla::SeekTarget>&, mozilla::IndexSequence<0>) 	obj-firefox/dist/include/mozilla/MozPromise.h:918
15 	xul.dll 	mozilla::detail::ProxyRunnable<mozilla::MozPromise<mozilla::MediaDecoder::SeekResolveValue, bool, 1>, mozilla::MediaDecoderStateMachine, mozilla::SeekTarget>::Run() 	obj-firefox/dist/include/mozilla/MozPromise.h:961
16 	xul.dll 	mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run() 	obj-firefox/dist/include/mozilla/TaskDispatcher.h:193
17 	xul.dll 	mozilla::TaskQueue::Runner::Run() 	xpcom/threads/TaskQueue.cpp:232
18 	xul.dll 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp:226
19 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1216
20 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp:361
21 	xul.dll 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:338
22 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:225
23 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:205
24 	xul.dll 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp:467
25 	nss3.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:397
26 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:95
27 	ucrtbase.dll 	_o__CIpow 	
28 	kernel32.dll 	BaseThreadInitThunk 	
29 	ntdll.dll 	__RtlUserThreadStart 	
30 	ntdll.dll 	_RtlUserThreadStart

this crash signature on windows is around since 51, but only affects aurora and beta so far (on 52.0b6 it's 0.12% of all crashes).

this originally regressed in 51.0b3 which seems to coincide with bug 1310224:
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=FIREFOX_51_0b2_RELEASE&tochange=FIREFOX_51_0b3_RELEASE
I don't see any crashes in 51.0.1 at this moment. Mark 51 as won't fix.
status-firefox51: affected → wontfix

Updated

a year ago
Rank: 15
Priority: -- → P1
(Assignee)

Updated

a year ago
Assignee: nobody → padenot
(Assignee)

Comment 2

a year ago
https://github.com/kinetiknz/cubeb/pull/237, fix being reviewed upstream.
(Assignee)

Updated

a year ago
Depends on: 1342363
(Assignee)

Comment 3

a year ago
Fixed by 1342363 and uplifted. Closing this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
status-firefox52: affected → wontfix
status-firefox53: affected → fixed
status-firefox54: ? → fixed
status-firefox-esr52: --- → fixed
You need to log in before you can comment on or make changes to this bug.