Select acct, TitleBar shouldn't display <folder> on <account>

VERIFIED FIXED in M11

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 1999090808M11: Win32/NT4, Linux/Redhat 6.0, Mac 8.5.1

Overview: Select the top level folder for an account (i.e. qatest20). The Title
Bar should state "Netscape: <account>" instead of placing the folder name.

Steps to reproduce:
1. Start Mail
2. Select the top level account folder (i.e. qatest on nsmail-2)
3. Look at the Title Bar and it displays "Netscape: qatest20 on nsmail-2 on
qatest20 on nsmail-2".

Actual Results: This is difficult to read.
Expected Results: Would like the Title Bar to only show the <account>
information. For instance "Netscape: qatest20 on nsmail-2" or "Netscape:
Earthlink" (when using a pretty name).
(Reporter)

Updated

19 years ago
Assignee: phil → alecf
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

19 years ago
Assigning to alecf, setting QA Contact to nbaca and adding lchiang to Cc: list.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Updated

19 years ago
Target Milestone: M11
(Assignee)

Comment 2

19 years ago
damn I love javascript.
fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Resolution: FIXED → ---
(Reporter)

Comment 3

19 years ago
Build 1999092209M11: NT4, Linux

After selecting the account the Title Bar adds "Mozilla" after the account. For
instance "news.mozilla.org" displays as "news.mozilla.orgMozilla" or "qatest20
on nsmail-2" displays as "qatest20 on nsmail-2Mozilla".
(Reporter)

Comment 4

19 years ago
Same results for the Mac.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

19 years ago
Arg. Looks like I was misspelling "separator" as "seperator"... but this was
being hidden by the bug that makes all IFRAMEs update the title.

With this fix (to be checked in tomorrow) it will display as
<accountname> - <productname>
or
<folder> on <accountname> - <productname>

as in
Earthlink - Mozilla
or
INBOX on Earthlink - Mozilla

All toplevel windows are using the same schema, "<title> - <product>" so jglick
should update the specs (since they won't say <product>: <title>)
(Reporter)

Comment 6

19 years ago
Should this be marked as Resolved/Fixed?
(Assignee)

Comment 7

19 years ago
nope, I haven't actually checked in yet (checkins take more time now because
they require approval, etc)
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
ok, it now says <account> - <product>

as soon as you load a message, it will clear the title entirely though.
This is not my bug, this is the appshell's bug - they are propagating titles
from IFRAMES all the way to the top of the document.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
Build 1999092409M11: Win32/NT4, Linux/Redhat 6.0, Mac 8.5.1
Verified Fixed. Although the title disappears quickly as Alec mentions.

Comment 10

18 years ago
UE spec updated to reflect this.  Thanks for the heads up nbaca!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.