Back-button doesn't work with frame after SHIFT+reload

VERIFIED DUPLICATE of bug 135648

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 135648
16 years ago
10 years ago

People

(Reporter: Daniel Schroeter, Assigned: asa)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020328 (and Mozilla
0.9.9)

If you go to a site that use frames and doesn't update the location bar you get it.

(Hope it's not a duplicate bug. There are so many back-button-bugs)

To reproduce:
1. Go to a site with the above condition (in this example we'll use
http://www.dpsg-wikinger.de/testDB/)

2. Click for example to "Eltern-Info" -> "Ausruestung" (it's in the middle)
3. Now press SHIFT an click to "Reload"
4. Okay. Bad Homepage. You will start at the beginning, BUT if you click now to
"Eltern-Info" -> "Ausruestung" (or somewhere else)..
5. Then press the back-button and nothing will happen.

You can skip it if you go to the history and move two (or more) sites back. If
you now press Forward you will come to a situation that nothing will happen if
you press forward.

Comment 1

16 years ago
The link changes one of the frames.  When you shift-reload, it reloads
everything from the top, so it reloads the original frame.  So when you go back,
it goes "back" to the original frame, but it's already there so nothing happens.
(Reporter)

Comment 2

16 years ago
Hi Andrew,

did you try it?

At my point 4 I'm in "Eltern-Info" -> "Ausruestung" and not in home. So if you
click back nothing happen. But mozilla should go to the home site (or wherever
you where before clicking to "Ausruestung").
If you do it without SHIFT+reload it works like expected. You go back to the
home site.

If you have the "bug" (nothing happen if you press back) and go now to the
history of the back button and take the second entry, then mozilla goes back.
Now you can press the forward button and nothing will happen. He is still there
(and the button isn't grey).

BTW: "Eltern-Info" moves from the middle to the right.....

Comment 3

16 years ago
Confirming with 20020421 Linux. Reporter I don't understand what you mean by
"Bad Homepage.". Could you clarify? At this point the loaded page looks fine...

If this isn't a dup it could be worth adding to bug 59387...
Status: UNCONFIRMED → NEW
Component: Browser-General → History: Session
Ever confirmed: true
Summary: Back-button doesn't work after SHIFT+reload → Back-button doesn't work with frame after SHIFT+reload

Comment 4

16 years ago
Bad and good homepages:
On a good homepage you see in the addressline always where you are. On 
http://www.dpsg-wikinger.de/testDB/ you see always the same Url. And if you do 
a reload in any sub-menu you will jump to the start. That's IMHO the different 
between good and bad homepages.

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 135648 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Verifying.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: doronr → docshell
You need to log in before you can comment on or make changes to this bug.