Incorrect encoding of words in header fields (RFC 2047)

RESOLVED INVALID

Status

MailNews Core
MIME
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: Claus Nielsen, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
According to RFC 2047:

[--- QUOTE (near top of page 7 of RFC 2047) ---]

Ordinary ASCII text and 'encoded-word's may appear together in the
same header field.  However, an 'encoded-word' that appears in a
header field defined as '*text' MUST be separated from any adjacent
'encoded-word' or 'text' by 'linear-white-spac

[---- END OF QUOTE ----]

I occationally recieve messages written in Mozilla mail with headers
like this:

X-Mailer: Mozilla 4.78 [en] (X11; U; Linux 2.4.9-31 i686)
Subject: Re: [NOVICE] =?iso-8859-1?Q?Hj=E6lp?=, grafikken spiller ikke!

The comma following the encoded word in the Subject causes my MUA (Evolution) to
NOT decode it - and rightly so as it isn't correctly encoded according to RFC 2047.

Comment 1

15 years ago
Ahem... What you describe seems to be caused by Netscape 4.78, not Mozilla.

I just tried with Mozilla 1.3b and it seems fine:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210
Subject: pokus =?ISO-8859-2?Q?as=F9=EC=B9qw=2C_asd?=

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.