Closed Bug 1340474 Opened 3 years ago Closed 3 years ago

Update web-platform-tests to revision eba2c70d536caaeef540966bc8ac7822417ab867

Categories

(Testing :: web-platform-tests, defect)

defect
Not set

Tracking

(firefox54 fixed)

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: jgraham, Unassigned)

References

Details

No description provided.
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/91e832455287
Update web-platform-tests to revision eba2c70d536caaeef540966bc8ac7822417ab867, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/043404978da9
Update web-platform-tests expected data to revision eba2c70d536caaeef540966bc8ac7822417ab867, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/656ee234214c
Remove jQuery link from window handler test, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/a4c8a72c5ad9
Add long timeouts to some IndexedDB tests, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/460a52510946
Fix instability in data url test caused by random behaviour of whitespace in URL, a=testonly
Blocks: 1332440
Pushed by Ms2ger@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/425b92cd2370
Update web-platform-tests to revision eba2c70d536caaeef540966bc8ac7822417ab867, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ae7735c28ae
Update web-platform-tests expected data to revision eba2c70d536caaeef540966bc8ac7822417ab867, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c37642c6f4c
Remove jQuery link from window handler test, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca41058f451a
Add long timeouts to some IndexedDB tests, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/aaef66127d84
Fix instability in data url test caused by random behaviour of whitespace in URL, a=testonly
FYI the correct fix to a permafail following a wpt upgrade is always to change the expectation metadata for the relevant test. In this case the test is /IndexedDB/idbdatabase_deleteObjectStore.htm so the metadata file is testing/web-platform/meta/IndexedDB/idbdatabase_deleteObjectStore.htm.ini. In this case it looks pretty clearly like what happened is that it got incorrectly set due to an intermittent timeout in the try run, so the file just needs to be deleted.

Not saying that you did the wrong thing with a backout in this case, but in general the fixup for this kind of issue is just as mechanical and easy to perform as a backout, whilst being significantly less disruptive.
Flags: needinfo?(james)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0bf3a9544a5c
Update web-platform-tests to revision eba2c70d536caaeef540966bc8ac7822417ab867, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/66e59fcc80b1
Update web-platform-tests expected data to revision eba2c70d536caaeef540966bc8ac7822417ab867, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/09e4c088bc00
Remove jQuery link from window handler test, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/4314100ab093
Add long timeouts to some IndexedDB tests, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/aba219418397
Fix instability in data url test caused by random behaviour of whitespace in URL, a=testonly
You need to log in before you can comment on or make changes to this bug.