Closed Bug 1340519 Opened 3 years ago Closed 3 years ago

Pref off full-duplex for Windows and Mac in beta

Categories

(Core :: WebRTC, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox52 + verified
firefox-esr52 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1324582 +++

There are drift issues with both Mac and Linux for which the fixes are too late to have sufficient confidence landing in beta, given risk.  We do expect the fixes to be in Aurora/53.
Comment on attachment 8838515 [details] [diff] [review]
pref off full_duplex in mac and windows for beta due to drift issues rs=jesup

rs=me

Approval Request Comment
[Feature/Bug causing the regression]: bug 1315928, bug 1335494 and the windows drift bug related to it

[User impact if declined]: Drift issues which can cause delay or "scratchy" mic audio, depending on the direction and type of drift.  On mac, frozen capture (bug 1335494)

[Is this code covered by automated tests?]: requires manual QA (repeated gum tests on real HW)

[Has the fix been verified in Nightly?]: N/A - non-full-duplex is still used for Android and in 51.

[Needs manual test from QE? If yes, steps to reproduce]:  See bug 1335494.  In general, just try webrtc calls and verify audio works properly/similar to 51

[List of other uplifts needed for the feature/fix]: none

[Is the change risky?]: no

[Why is the change risky/not risky?]: pref off of new feature for windows/mac; same as was done for 51 for a different reason.

[String changes made/needed]: none
Attachment #8838515 - Flags: review+
Attachment #8838515 - Flags: approval-mozilla-beta?
Comment on attachment 8838515 [details] [diff] [review]
pref off full_duplex in mac and windows for beta due to drift issues rs=jesup

pref off new feature on windows and mac in beta52
Attachment #8838515 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/546f359ac8c0dbb466e6b307a0f906ea6df62a45
Status: NEW → RESOLVED
Closed: 3 years ago
Rank: 10
Resolution: --- → FIXED
We tested the disabling of full-duplex using Firefox 52.0b8 by runing several WebRTC calls with various services between the following platforms: Windows 7 x64, Windows 10 x64, Mac OS X 10.11 and Mac OS X 10.12.
No regressions were spotted and only one known issue was encountered (bug 1337810).

Complete details of our testing can be found in the following etherpad: https://public.etherpad-mozilla.org/p/1340519
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.