POST takes a long time when the file is modified before submitting

NEW
Unassigned

Status

()

Firefox
File Handling
P5
normal
8 months ago
6 months ago

People

(Reporter: mayhemer, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
Firefox nightly, bugzilla.mozilla.org (production).

It happens to me quite often that when I press the [Submit] button on the Create New Attachment page (freshly opened), the POST never gets a response.

So far I'm pretty uncertain on STR.

- Pressing stop and pressing [Submit] again doesn't fix the problem.
- Pressing stop, reloading the page (leaving the fields filled) and pressing [Submit] again doesn't fix the problem.
- Hard reloading (Ctrl-F5) the page, refilling all the fields and pressing [Submit] so far always worked for me as a fix.
- Middle click on the reload button in the address bar and refilling again also fixes the problem

Something tells me this is not related to bug 1304056.


(I tried to reproduce suspected STR *on landfill.m.o*, 4.4, but submitting a patch there gives me Malformed multipart POST error...)
(Reporter)

Comment 1

8 months ago
I think it happens when I modify the file on disk between adding it to the file field and submitting the form.
(Reporter)

Comment 2

8 months ago
I'll test with a simpler test case and if found a general problem in the browser I'll move to another component.
Status: NEW → UNCONFIRMED
Ever confirmed: false
it's also possible at times bugzilla is under too much load to handle the request -- let me know what you find. :)
(In reply to Dylan Hardison [:dylan] from comment #3)
> it's also possible at times bugzilla is under too much load to handle the
> request -- let me know what you find. :)

Is this something which can be resolved by using dedicated webheads for file uploads?
Flags: needinfo?(dylan)
(In reply to Emma Humphries ☕️ [:emceeaich] (UTC-8) +needinfo me from comment #4)
> (In reply to Dylan Hardison [:dylan] from comment #3)
> > it's also possible at times bugzilla is under too much load to handle the
> > request -- let me know what you find. :)
> 
> Is this something which can be resolved by using dedicated webheads for file
> uploads?

Pointless speculation until we hear back from the reporter.
Nothing is going to be much better until we aren't serving static files with apache.
Flags: needinfo?(dylan)
(Reporter)

Comment 6

8 months ago
I can confirm this is happening when the patch is modified between adding reference to it to the submit form (or dropping it from file explorer on to the [ Browse ] button) and submitting the form.

This is not bugzilla issue but browser one.
Status: UNCONFIRMED → NEW
Component: Bug Creation/Editing → File Handling
Ever confirmed: true
Product: bugzilla.mozilla.org → Firefox
Version: Production → Trunk

Comment 7

6 months ago
I'm not placing this in the File Handling backlog yet, not sure if the code for uploads is in this component either.
Priority: -- → P5
Summary: Sometimes POST submitting a patch takes forever to respond → POST takes a long time when the file is modified before submitting
(Reporter)

Comment 8

6 months ago
I think this is duplicate of bug 1353629 (originally bug 1304056)

Comment 9

6 months ago
This describes a specific symptom that may be solved by the PBlob refactoring, so it may be better to set it as a dependency and close it when it's actually fixed.
Depends on: 1353629
You need to log in before you can comment on or make changes to this bug.