Activity stream - Add snackbar when the user chooses to bookmark a website from Top sites or Highlights

RESOLVED DUPLICATE of bug 1401179

Status

()

Firefox for Android
General
P3
enhancement
Rank:
2
RESOLVED DUPLICATE of bug 1401179
8 months ago
22 days ago

People

(Reporter: carmenf, Unassigned)

Tracking

54 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 affected)

Details

(Whiteboard: [MobileAS])

(Reporter)

Description

8 months ago
Environment: 
Device: Samsung Galaxy Note 4 (Android 5.0.1);
Build: Nightly 54.0a1 (2017-02-17);

Prerequisites: Activity stream on Android is enabled.

Steps to reproduce:
1. Open Fennec;
2. Go to about:home;
3. Tap on 3 dots context menu icon from a website (either Top sites or Highlights areas);
4. Tap on  "Bookmark"

Expected result:
Context menu is dismissed and website is bookmarked. 
Bookmark icon is filled.

Actual result:
It should be nice to also display the snackbar "Bookmark added|OPTIONS"

Notes:
It should also display a snackbar when bookmark is removed "Bookmark removed".
(Reporter)

Updated

8 months ago
Whiteboard: [MobileAS]
Priority: -- → P2

Comment 1

7 months ago
"Bookmark Added"

"Bookmark Removed" 

Seems like reasonable toast messages for this feature.
Blocks: 1311099
Blocks: 1377248

Updated

3 months ago
Rank: 2
Priority: P2 → P3
Implemented in bug 1401179.
Status: NEW → RESOLVED
Last Resolved: 22 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1401179
You need to log in before you can comment on or make changes to this bug.