BuddyBuild nightly/development builds fail because of app group changes

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
P1
normal
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: sleroux, Assigned: sleroux)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios7.0+)

Details

(Whiteboard: [MobileCore])

Attachments

(1 attachment)

(Assignee)

Description

11 months ago
Whenever Buddybuild runs a Nightly build after running a development build from integrating, the app groups in the developer portal get modified to the previously built scheme's app group. For example, after building FenncEnterprise, when FirefoxNightly is built, the app groups for the app ids associated with FirefoxNightly are set to the FennecEnterprise app group.

It's also worth noting that we have this same issue when producing our Beta/Production releases which requires me to go into the portal every time we make a build to invalidate/re-generate the provisioning profiles.
(Assignee)

Updated

11 months ago
Summary: BuddyBuild nightly/developments fail because of app group changes → BuddyBuild nightly/development builds fail because of app group changes
(Assignee)

Comment 1

11 months ago
Note: Initial investigate in the past points to Xcode's automatic profile management setting being the cause for the updating and potentially cached .xcconfig values when switching between schemes causing the incorrect app group names.

Farhan mentioned yesterday to also investigate moving BB from automatic profile management to manual management.
(Assignee)

Updated

11 months ago
Iteration: --- → 1.16
tracking-fxios: ? → 7.0+
Priority: -- → P1
(Assignee)

Comment 2

11 months ago
Note: This also happens whenever we build the FirefoxBeta builds as well.
(Assignee)

Comment 3

11 months ago
Created attachment 8842127 [details] [review]
Link to Github pull-request: https://github.com/mozilla-mobile/firefox-ios/pull/2472
Attachment #8842127 - Flags: review?(fpatel)

Updated

11 months ago
Attachment #8842127 - Flags: review?(fpatel) → review+
(Assignee)

Comment 4

11 months ago
v7.x 12e0af73f8aa68a3a5bb107fd532188ebc85a22c
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.