[DOGFOOD] gfx text fields scramble when scrolling

VERIFIED FIXED in M12

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
18 years ago

People

(Reporter: mcafee, Assigned: pavlov)

Tracking

Trunk
Other
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] will verify in 12/1 build.)

Attachments

(1 attachment)

Reporter

Description

20 years ago
linux, apprunner.
Go to bug 12902, scroll the cc list to the right,
then to the left.  Things redraw funny.

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 1

20 years ago
Accepting bug.

Updated

20 years ago
Target Milestone: M11 → M12

Comment 2

20 years ago
Changing milestone of all Selection Scrolling bugs to M12.

Updated

20 years ago
Assignee: kin → pavlov
Status: ASSIGNED → NEW

Comment 3

20 years ago
Reassigning to pavlov@netscape.com.

Akkana, Pavlov, and I got together to look at this.

Turns out it's a problem in the gtk implementation of the method
nsScrollbar::SetPosition(). The view scrolling code expects SetPosition() to
move the scrollbar thumb without causing a scroll to happen, but the gtk
implementation does trigger a scroll, so what ends up happening is that
nsScrollingView::ScrollTo() ends up scrolling the view twice because it calls
both SetPosition() and Scroll().

To fix this, the code in SetPosition() needs to be modified so that it doesn't
emmit a scroll signal.

I'm not sure of the urgency to fix this bug since things seem to work fine when
using Gfx Scrollbars. I believe the plan right now is to have all platforms
switch over to using Gfx Scrollbars before the beta.

Updated

20 years ago
Blocks: 18353

Updated

20 years ago
Summary: gfx text fields scramble when scrolling → [DOGFOOD] gfx text fields scramble when scrolling

Comment 4

20 years ago
Marking this bug as dogfood.

Updated

20 years ago
Blocks: 17804
Reporter

Comment 5

20 years ago
Until gfx scrollbar primetime, we might be able
to check the pref and conditionally not do one
of the SetPostion() or Scroll() calls.

Updated

20 years ago
Whiteboard: [PDT+]

Comment 6

20 years ago
Putting on the PDT+ radar.

Comment 7

20 years ago
*** Bug 17256 has been marked as a duplicate of this bug. ***

Comment 8

20 years ago
*** Bug 19169 has been marked as a duplicate of this bug. ***
Assignee

Updated

20 years ago
Whiteboard: [PDT+] → [PDT+] 12/3/99

Comment 10

20 years ago
*** Bug 18353 has been marked as a duplicate of this bug. ***
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Assignee

Comment 11

20 years ago
this is fixed with gfx scrollbars on.  i've added a comment to the gtk code with
a pointer to this bug incase we ever get around to fixing it for native
scrollbars

Updated

20 years ago
Whiteboard: [PDT+] 12/3/99 → [PDT+] will verify in 12/1 build.

Comment 12

20 years ago
will verify in 12/1 build.

Updated

20 years ago
Status: RESOLVED → VERIFIED
OS: Solaris → Linux
Hardware: Sun → Other

Comment 13

20 years ago
looks fixed to me....mcafee reopen if you're stil not seeing it fixed..

verified in 12/1 build.

Comment 14

20 years ago
*** Bug 19516 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.