Closing Print Preview window results in a crash

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
P1
major
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: dcone (gone))

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2002-03-28-08
Platform: OS 9 and OS X
Expected Results: Print preview window should close and application should not crash
What I got: Application crashes after window is closed

Steps to reproduce:

1) Go to url- http://home.netscape.com/
2) Select Print Preview from File menu
3) In Preview, press Command - W ( OS X) or File->Close (0S 9)
4) Crash occur after window closes.


Stack trace from OS X crash reporter:



Date/Time:  2002-03-28 15:19:57 -0800
OS Version: 10.1.3 (Build 5Q45)
Host:       localhost

Command:    Mozilla
PID:        469

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000004

Thread 0 Crashed:
 #0   0x00000004 in 0x4
 #1   0x029eb7e0 in PresShell::Destroy(void)
 #2   0x029eae34 in 0x29eae34
 #3   0x029eaa24 in PresShell::Release(void)
 #4   0x0061e294 in nsCOMPtr_base::_dt(void)
 #5   0x0211c9b0 in PrintData::_dt(void)
 #6   0x0211f394 in DocumentViewerImpl::Destroy(void)
 #7   0x0268edb0 in nsDocShell::Destroy(void)
 #8   0x026b00b8 in nsWebShell::Destroy(void)
 #9   0x02b7dff0 in nsHTMLFrameInnerFrame::_dt(void)
 #10  0x029d70cc in nsFrame::Destroy(nsIPresContext *)
 #11  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #12  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #13  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #14  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #15  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #16  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #17  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #18  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #19  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #20  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #21  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #22  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #23  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #24  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #25  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #26  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #27  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #28  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #29  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #30  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #31  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #32  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #33  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #34  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #35  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #36  0x02af04bc in nsBoxFrame::Destroy(nsIPresContext *)
 #37  0x02aea654 in nsFrameList::DestroyFrames(nsIPresContext *)
 #38  0x029d4478 in nsContainerFrame::Destroy(nsIPresContext *)
 #39  0x02abe5d0 in ViewportFrame::Destroy(nsIPresContext *)
 #40  0x02b1739c in FrameManager::Destroy(void)
 #41  0x029eb824 in PresShell::Destroy(void)
 #42  0x0211f4c8 in DocumentViewerImpl::Destroy(void)
 #43  0x0268edb0 in nsDocShell::Destroy(void)
 #44  0x026b00b8 in nsWebShell::Destroy(void)
 #45  0x024a3fcc in nsXULWindow::Destroy(void)
 #46  0x024903e0 in nsWebShellWindow::Destroy(void)
 #47  0x0249d72c in nsChromeTreeOwner::Destroy(void)
 #48  0x026f6360 in GlobalWindowImpl::ReallyCloseWindow(void)
 #49  0x026fb4d8 in GlobalWindowImpl::CloseWindow(nsISupports *)
 #50  0x026e85d0 in nsJSContext::ScriptEvaluated(int)
 #51  0x026e738c in nsJSContext::CallEventHandler(void *, void *, unsigned int,
void *, int *, int)
 #52  0x02706704 in nsJSEventListener::HandleEvent(nsIDOMEvent *)
 #53  0x01fdf350 in HandleEventSubType__22nsEventListenerManagerFP16nsListenerStru
 #54  0x01fe1998 in HandleEvent__22nsEventListenerManagerFP14nsIPresConte
 #55  0x0221d574 in HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP11n
 #56  0x024fc288 in DispatchCommandTo__12MenuHelpersXFP16nsIWeakReferenceP10nsICon
 #57  0x025035ac in nsMenuItemX::DoCommand(void)
 #58  0x024f976c in nsMenuBarX::CommandEventHandler(OpaqueEventHandlerCallRef *)
 #59  0x73118b08 in DispatchEventToHandlers
 #60  0x73101d98 in SendEventToEventTargetInternal
 #61  0x731b65b8 in SendEventToEventTarget
 #62  0x7310ba6c in SendHICommandEvent
 #63  0x731a81cc in SendMenuItemSelectedEvent
 #64  0x7312c6fc in HandleKeyboardEvent
 #65  0x73118b08 in DispatchEventToHandlers
 #66  0x73101d98 in SendEventToEventTargetInternal
 #67  0x73150038 in SendEventToEventTargetWithOptions
 #68  0x731a007c in HandleKeyboardEvent
 #69  0x731ac044 in ToolboxEventDispatcherHandler
 #70  0x73118bb4 in DispatchEventToHandlers
 #71  0x73101d98 in SendEventToEventTargetInternal
 #72  0x731b65b8 in SendEventToEventTarget
 #73  0x731d2910 in ToolboxEventDispatcher
 #74  0x731cfc7c in CallEventDispatchHook
 #75  0x73179468 in GetOrPeekEvent
 #76  0x731a1468 in GetNextEventMatchingMask
 #77  0x731ae408 in WNEInternal
 #78  0x731c5508 in WaitNextEvent
 #79  0x024e0a60 in nsMacMessagePump::GetEvent(EventRecord &)
 #80  0x024e093c in nsMacMessagePump::DoMessagePump(void)
 #81  0x024e02cc in nsAppShell::Run(void)
 #82  0x0249332c in nsAppShellService::Run(void)
 #83  0x004cc224 in main1(int, char **, nsISupports *)
 #84  0x004ccc6c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x00000004 srr1: 0x4200f030                vrsave: 0x00000000
   xer: 0x2000000e   lr: 0x029eb7e0  ctr: 0x00000005   mq: 0x00000000
    r0: 0x00000005   r1: 0xbfffcfa0   r2: 0x027fef30   r3: 0x03cdaa00
    r4: 0x03620260   r5: 0x000f13a0   r6: 0x00000040   r7: 0x0362114c
    r8: 0x00000003   r9: 0x00000000  r10: 0x000461a0  r11: 0x80003710
   r12: 0x0458b8d0  r13: 0x00000000  r14: 0x00115308  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000007
   r20: 0x028da8c0  r21: 0x00115308  r22: 0x00000001  r23: 0x03ae5b60
   r24: 0x00000001  r25: 0x02bd9690  r26: 0x02c4acd8  r27: 0x02c4ad50
   r28: 0x00000000  r29: 0x00000000  r30: 0x00000000  r31: 0x03cdac40

**********
(Reporter)

Comment 1

17 years ago
*** Bug 134071 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

17 years ago
Adding macsbug stack trace soon.
Severity: normal → major
Priority: -- → P1
Summary: Closing Print Preview window results in a crash → Closing Print Preview window results in a crash
(Reporter)

Comment 3

17 years ago
Created attachment 76656 [details]
Macsbug stdlog file from crash

Comment 5

17 years ago
->>
Assignee: rods → dcone
Keywords: crash
(Assignee)

Comment 6

16 years ago
Chris.. can you re-test this.. seems to work for me.  Re-open if you can still
see this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
No longer occurs in the OS X 2002-06-26-06 branch or OS 9 2002-06-26-05 branch.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.