Closed Bug 1340822 Opened 3 years ago Closed 3 years ago

Move nursery and caches from ZoneGroup back to the runtime

Categories

(Core :: JavaScript: GC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: bhackett, Assigned: bhackett)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
The vision for bug 1323066 is to have separate nurseries for each zone group, to allow for single threaded access in a preemptively scheduled runtime.  Right now, though, nurseries each require a minimum of 1MB of space for their allocated chunk, and having multiple enabled nurseries in a runtime will increase our memory usage.  Pretty soon Quantum DOM work will be start using different zone groups for each tab group, and to avoid these memory regressions it would be good to move the nursery back to the runtime until we have a strategy for reducing the minimum memory required for a nursery and putting a limit on the per-runtime maximum amount of nursery memory.  This is fine to do for a cooperatively multithreaded runtime.

There is a similar issue for the caches now stored on the zone group, and previously stored on the runtime/context.  Moving these back to the runtime will make ZoneGroup pretty lightweight and easily usable by Gecko for grouping zones.

Sorry about the churn...
Attachment #8838887 - Flags: review?(jcoppeard)
Assignee: nobody → bhackett1024
Attachment #8838887 - Flags: review?(jcoppeard) → review+
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a40af83f562a
Move nursery and caches from ZoneGroup back to the runtime, r=jonco.
https://hg.mozilla.org/mozilla-central/rev/a40af83f562a
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Duplicate of this bug: 1341026
Duplicate of this bug: 1341299
Duplicate of this bug: 1341311
You need to log in before you can comment on or make changes to this bug.