Closed Bug 1340869 Opened 3 years ago Closed 3 years ago

Crash in mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::RecordTelemetryProbes

Categories

(Core :: XPCOM, defect, critical)

52 Branch
Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed

People

(Reporter: calixte, Assigned: smaug)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [clouseau])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-598aec95-cc5f-4325-994c-edffc2170218.
=============================================================

There are 3 crashes on nightly 54 with buildid 20170218030212.
In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1339135.

[1] https://hg.mozilla.org/mozilla-central/rev?node=05a99b44e42436a163843a941cf9c8573f93d991
Flags: needinfo?(bugs)
Ok, we need similar null check as in https://hg.mozilla.org/mozilla-central/annotate/d11c29c1db3a/layout/base/nsRefreshDriver.cpp#l644
Flags: needinfo?(bugs)
Assignee: nobody → bugs
Attachment #8838935 - Flags: review?(afarre)
Blocks: 1340418
Comment on attachment 8838935 [details] [diff] [review]
telemetry_crash.diff

Perhaps stone gets to this sooner.
Attachment #8838935 - Flags: review?(sshih)
Comment on attachment 8838935 [details] [diff] [review]
telemetry_crash.diff

LGTM. Thanks.
Attachment #8838935 - Flags: review?(sshih) → review+
Attachment #8838935 - Flags: review?(afarre)
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ce3e5778328
crash @ RefreshDriverVsyncObserver::RecordTelemetryProbes, r=stone
Duplicate of this bug: 1340444
https://hg.mozilla.org/mozilla-central/rev/1ce3e5778328
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Duplicate of this bug: 1340418
Whiteboard: [clouseau]
You need to log in before you can comment on or make changes to this bug.