X items failed to import. The last error was 2147500037

RESOLVED INVALID

Status

Calendar
Import and Export
RESOLVED INVALID
10 months ago
8 months ago

People

(Reporter: jffry, Unassigned)

Tracking

Lightning 4.7.4

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8838945 [details]
Home2017@gmail.ics

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170210223443

Steps to reproduce:

I have an .ics, which I can import into a fresh local calendar, but when trying to import into a network calendar (hosted by posteo.de), I get the above error message.


Actual results:

The network calendar is then marked with a yellow triangle and an exclamation mark "The calendar X is momentarily not available".

The events do not seem to be imported. Right click "synchronise calendar", makes the events appear, and turning the offline support on and off and on again removes the warning triangle.


Expected results:

I would either have expected the file to import without error, or to receive a reasonable error message.

The current message is very cryptic and should be improved.

Updated

10 months ago
Attachment #8838945 - Attachment mime type: text/calendar → text/plain

Comment 1

10 months ago
The ICS itself looks good.

What type of network calendar is this? ICS (aka WebDAV), CalDAV, ...?

Have you made sure the calendar is writable for you serverside (you can simply check this by creating an event from within Lightning in that calendar - if it doesn't work, it isn't writable)? For ICS calendars hosted on the internet this is typically not the case.
Flags: needinfo?(jffry)
(Reporter)

Comment 2

10 months ago
In the mean time, I have tested importing many .ics files, and have the same problem every time.

The calendar is CalDAV (https://posteo.de/en/site/features#featurescalendar)

The calendar is writeable serverside. As I said, the workaround is to right click "synchronise calendar", and then to cycle the offline support.

I can create individual events with no problem.

Comment 3

10 months ago
Ok, thanks. Can you please enable calendar.debug.log and calendar.debug.log.verbose in TB's advanced configuration, open TB's error console, clear all existing entries, reproduce the issue and attach everything you get in the error console when doing so to this bug?

If you use the current TB 52 beta for doing that, copying from the error console will be much more convinient because you wouldn't have to copy every single entry separately.
(Reporter)

Comment 4

10 months ago
Here is the contents of the error console:

Timestamp: 05/03/17 15:06:16
Error: uncaught exception: 2147746065
Source File: resource:///modules/activity/autosync.js
Line: 210

CalDAV: itemUri.spec = https://posteo.de:8443/calendars/jffry/default/v2mptvolta66qtkb85si9mr5kc%40test.com.ics

CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
CREATED:20170128T080958Z
LAST-MODIFIED:20170128T080958Z
DTSTAMP:20170216T204733Z
UID:v2mptvolta66qtkb85si9mr5kc@test.com
SUMMARY:My test event
STATUS:CONFIRMED
DTSTART:20170310T200000Z
DESCRIPTION:my test description
LOCATION:my test location
SEQUENCE:0
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR

CalDAV: recv: 

CalDAV: Item added to Home successfully

CalDAV: send(https://posteo.de:8443/calendars/jffry/default/): <?xml version="1.0" encoding="UTF-8"?>
<C:calendar-multiget xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><D:getetag/><C:calendar-data/></D:prop><D:href>/calendars/jffry/default/v2mptvolta66qtkb85si9mr5kc%2540test.com.ics</D:href></C:calendar-multiget>

Timestamp: 05/03/17 15:07:25
Warning: CalDAV: Get failed: CalDAV: Error: got status 404 fetching calendar data for Home, [xpconnect wrapped calIOperationListener]
Source File: file:///home/jeff/.icedove/2k7vdn9f.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js
Line: 1219

Timestamp: 05/03/17 15:07:28
Warning: There has been an error reading data for calendar: Home.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80004005. Description: CalDAV: Error: got status 404 fetching calendar data for Home, [xpconnect wrapped calIOperationListener]
Source File: file:///home/jeff/.icedove/2k7vdn9f.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 962

Timestamp: 05/03/17 15:07:28
Warning: There has been an error reading data for calendar: Home.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: 
Source File: file:///home/jeff/.icedove/2k7vdn9f.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 962

http channel Listener OnDataAvailable contract violation

CalDAV: recv: null

aChangeLogListener=undefined
calendarURI=https://posteo.de:8443/calendars/jffry/default/ 
iscached=true
this.mQueuedQueries.length=0

CalDAV: onStopRequest: no reader

Timestamp: 05/03/17 15:07:46
Error: uncaught exception: 2147746065
Source File: resource:///modules/activity/autosync.js
Line: 210
> CalDAV: Error: got status 404 fetching calendar data for Home

It looks like the calendar is set up incorrectly, can you verify that you are using the right URL? If afterwards this is still an issue I am happy to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(jffry)
Resolution: --- → INVALID
(Reporter)

Comment 6

8 months ago
Define "set up incorrectly".

The workaround I detailed in the report, works, and otherwise events are synchronised correctly.

So, yes, I think the URL is correct.
You need to log in before you can comment on or make changes to this bug.