Firefox crashes when switching to a newly open link in new tab

RESOLVED WORKSFORME

Status

()

Firefox for iOS
General
P2
critical
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Adrian Oniga, Unassigned)

Tracking

({crash})

unspecified
All
iOS
crash

Firefox Tracking Flags

(fxios8.0+)

Details

(Whiteboard: [MobileAS])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

1. Open Firefox
2. Long tap on  a site from Top sites list
3. Tap "Open in New Tab"
4. From the tab counter switch to the new open tab really fast, before it gets a chance to fully load the new page


Actual results:

2. Context menu is displayed
3. New tab is opened
4.New tab is opened and you are able to use it


Expected results:

4. New tab is opened for a brief period of time and then Firefox crashes
(Reporter)

Comment 1

a year ago
Found on iPhone 6, iOS 10.2.1, Firefox version 7.0(1), buddybuild #1696
Can you attach a crash report? Does this happen in 6.0?
Severity: normal → critical
Status: UNCONFIRMED → NEW
tracking-fxios: --- → ?
Ever confirmed: true
Flags: needinfo?(onigaadrian86)
Keywords: crash
Hardware: Other → All
Created attachment 8839086 [details]
Client  20-02-2017, 11-28.crash
(Reporter)

Comment 4

a year ago
This bug can not be reproduced on Firefox version 6.0 due to nonexistent feature on this version (long tap on top sites does not show a contextual menu, so no open in new tab option). Opening a link in a new tab does not crash the app(in either version)
Flags: needinfo?(onigaadrian86)
Whiteboard: [MobileAS]
tracking-fxios: ? → 8.0+
Priority: -- → P2
Whiteboard: [MobileAS] → [MobileCore]
Whiteboard: [MobileCore] → [MobileAS]
I've tried this and I can't reproduce it; I think this is already fixed due to some favicon refactoring (according to Farhan). Please reopen if it's reproducible still!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.