Closed Bug 1340914 Opened 3 years ago Closed 10 months ago

after shader editor refresh nothing is displayed anymore

Categories

(DevTools Graveyard :: WebGL Shader Editor, defect)

36 Branch
x86_64
Windows 7
defect
Not set

Tracking

(firefox-esr52 wontfix)

RESOLVED WONTFIX
Tracking Status
firefox-esr52 --- wontfix

People

(Reporter: trass3r, Assigned: emk)

References

Details

(Keywords: regression)

Attachments

(1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.88 Safari/537.36 Vivaldi/1.8.755.3

Steps to reproduce:

http://demo.marpi.pl/archan/black_rain/
the demo works normally, scene and raindrops are shown
open shader editor
reload to enable the editor


Actual results:

just black screen and the enter button


Expected results:

scene is displayed correctly
Component: Untriaged → Developer Tools: WebGL Shader Editor
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Regression range:
Last good revision: 33c0181c4a25 (2014-10-20)
First bad revision: 29fbfc1b31aa (2014-10-21)
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=33c0181c4a25&tochange=29fbfc1b31aa

alice, any idea about the regressing bug?
Flags: needinfo?(alice0775)
Keywords: regression
Blocks: 1081990
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 53 Branch → 36 Branch
Too late for firefox 52, mass-wontfix.
victor,  is this on your radar? Looks like this hasn't worked since 2014 so maybe it's just general backlog.
Product: Firefox → DevTools
Apply this patch on top of a patch from bug 1342237.
Attachment #9031617 - Flags: review?(vporof)
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Comment on attachment 9031617 [details] [diff] [review]
Use Cu.exportFunction so that content can access Function properties

Shader Editor will be removed soon. (bug 1342237)
Attachment #9031617 - Attachment is obsolete: true
Attachment #9031617 - Flags: review?(vporof)
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.