Links regarding becoming a contributor should be removed - or renamed & revised - for registered contributors

RESOLVED DUPLICATE of bug 1365078

Status

RESOLVED DUPLICATE of bug 1365078
2 years ago
2 years ago

People

(Reporter: John99, Assigned: guigs)

Tracking

Details

(Whiteboard: [1st2weeks])

Attachments

(3 attachments)

Created attachment 8838974 [details]
03-The target audience *Registered users* get *access denied* and no option to be a contributor

There are links in various places asking if you want to be a contributor. These waste space and are superfluous once registered as a contributor so should be removed. They almost certainly do not work as intended.

Alternatively if these are to be used as a method of someone changing status or gaining an additional privilege they should be renamed  for existing contributors, ideally whilst looking at the privileges already in use.

WHAT HAPPENS
For instance on the support contributors forum page is a particularly bad example
Link:
> https://support.mozilla.org/t5/Contributor-Forums/ct-p/contributors
Breadcrumbs: 
> Mozilla > Mozilla Support - English > Forums
Title:
> Contributor Forums 
Text at top of screen:
> Welcome to the Support Questions, Interested in becoming a contributor - > Request to be a Contributor 
Note that if you are not signed in at all you get a page including a message telling you that you need to be a contributor but NOT offering the link for you to register as a contributor. (It does correctly offer links to sign in or to register. screenshot 2 attached)
Message:
>You must be signed in to access this part of the community.

A none contributor *registered* user trying to access that page.
Someone who may know that page link, and may hope and wish to register as a contributor gets an access denied page and no link to become a contributor. screenshot 3 attached.

WHAT SHOULD HAPPEN
So in addition addition to the stated title of this bug maybe it would be beneficial for registered user to get more appropriate information.

I am aware that there are similar links and other pages involved. 
I am also aware that there are differing methods of trying to gain registration including Google forms and mailto links. This should surely be rationalised over the new Lithium Sumo site to be appropriate to the credentials of the person viewing it, and probably it would be good to not rely on Mailto links and google forms as exclusive methods of registering.

SEE ALSO
Initial related Sumo forum thread is 
>  Request to be a contributor - remove link once registered
> https://support.mozilla.org/t5/SUMO-community-discussions/Request-to-be-a-contributor-remove-link-once-registered/m-p/1362703#M25578
These bugs do not default to having any owner QA contact or cc list. It is probably inappropriate to cc Lithium or use Whiteboard so will cc some of Sumo staff.
Also I intended to attach 3 screenshots only one attached I will attach the other two separately
Created attachment 8838976 [details]
01-Exisrting contributor invir=ted to be a contributor
Created attachment 8838977 [details]
02-not signed in - ok

Comment 4

2 years ago
I'm assigning this to Rachel as she will be looking at the onboarding piece.

Rachel, please update this bug once you've figured out the user flows.
Assignee: nobody → rmcguigan
Whiteboard: [1st2weeks]

Updated

2 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Component: Lithium Migration → Ask a Question Workflow
Product: support.mozilla.org → support.mozilla.org - Lithium
This was my fault for updating the wrong place - trello instead of here. John you can access the current user flows with this document: https://docs.google.com/document/d/1V6k6vxYBZxMcIkAmVVlMCjVIaWdAC1A9qJs4VorTXZw/edit?usp=sharing

I would love your feedback on it, as I am sure there are pros and cons for both users and contributors.
Flags: needinfo?(John99-bugs)
Thanks for the link, I can open that doc but have not yet had time to study it.
I will leave the NI as a reminder for me to look at the document.

What is the current position on the Read Only Lithium site is it worth me looking at what happens on that or is it better tyo wait until we move back to Lithium. Also if Lithium changes are being made do contributors get access to the Lithium stage eqivalent so we can test things out before they go live. And the ability once there to test as users with differing permisions/roles i.e. as our own site moderator role, but also as an ordinary contributor, and an ordinary visitor ?
I guess the document is still in early stages. I have made some comments on it.

Adding NI Rachel.
What is the latest on 
1.) This bug.
2.) Access to Lithium & Lithium pre release.
Flags: needinfo?(John99-bugs) → needinfo?(rmcguigan)
Thanks for the comments in the document John. Wait until we move platforms. I am marking this as a duplicate of the Onboarding Experience meta bug.
Flags: needinfo?(rmcguigan)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365078
You need to log in before you can comment on or make changes to this bug.