Closed Bug 1340960 Opened 3 years ago Closed 3 years ago

Crash in java.lang.IllegalArgumentException: printJobName cannot be empty at android.print.PrintManager.print(PrintManager.java)

Categories

(Firefox for Android :: General, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 54
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed

People

(Reporter: njn, Assigned: jchen)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-7153d1b5-0152-4e64-a659-6bfa62170219.
=============================================================

New crash, first appeared in Nightly 20170206110132, though it's infrequent enough that the root cause may have landed a few days before that.

jchen, any ideas?
Flags: needinfo?(nchen)
Looks like bug 1333590
Assignee: nobody → nchen
Blocks: 1333590
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
generatePDF returns a Promise. We shouldn't feed the Promise to the
callback, but rather invoke the callbacks when the Promise is
resolved/rejected.
Attachment #8840093 - Flags: review?(s.kaspari)
Attachment #8840093 - Flags: review?(s.kaspari) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4e3d73a1b3b4
Correctly invoke print callbacks; r=sebastian
https://hg.mozilla.org/mozilla-central/rev/4e3d73a1b3b4
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
You need to log in before you can comment on or make changes to this bug.