configure.in compiler issues on solaris

RESOLVED FIXED

Status

Directory
LDAP C SDK
--
critical
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: dmose, Assigned: dmose)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
Yesterday, early in the day, builds on worms (static, and at that time parallel)
were displaying the following error:

gmake[5]: Entering directory
`/builds/tinderbox/SunOS_5.8_Depend/mozilla/directory/c-sdk/config'
gcc -o now.o -c     -Wall -pthreads -O -fPIC  -UDEBUG  -DMOZILLA_CLIENT=1
-DNDEBUG=1 #ifdef\ __cplusplus void\ exit\ \(int\)\; #endif -DXP_UNIX=1 -DSVR4=1
-DSYSV=1 -D__svr4=1 -D__svr4__=1 -DSOLARIS=1 -DHAVE_FCNTL_FILE_LOCKING=1
-D_PR_HAVE_OFF64_T=1 -D_LARGEFILE64_SOURCE=1 -DHAVE_LCHOWN=1 -DHAVE_STRERROR=1
-D_REENTRANT=1 -DHAVE_POINTER_LOCALTIME_R=1  -DFORCE_PR_LOG -D_PR_PTHREADS
-UHAVE_CVAR_BUILT_ON_SEM   now.c

Note the goofy and incorrect ifdef stuff on the command line.

Then, sometime mid-day, that problem went away and the following error started
showing up:

gmake[6]: Entering directory
`/builds/tinderbox/SunOS_5.8_Depend/mozilla/directory/c-sdk/ldap/include'
../../config/./nsinstall -D
/builds/tinderbox/SunOS_5.8_Depend/mozilla/dist/public/ldap
perl ./../build/replace.pl \
	LDAP_VENDOR_NAME="mozilla.org" \
		LDAP_VENDOR_VERSION="500" \
		< ldap-standard-tmpl.h >
/builds/tinderbox/SunOS_5.8_Depend/mozilla/dist/public/ldap/ldap-standard.h
/bin/sh:
/builds/tinderbox/SunOS_5.8_Depend/mozilla/dist/public/ldap/ldap-standard.h:
cannot create

This turned out to be a parallel builds issue (bug already filed), so turning
off the parallel builds on worms made this problem go away.

Just before fixing the parallel builds, I tweaked configure.in with what I
thought was an obvious bugfix, but in retrospect, I think it's just wrong.  I
switched a couple of GCC tests in configure.in because I was having problems
with autoconf using forte switches on gcc command lines.

This change, however, broke dcran's forte builds, and might well break nebiros
builds once its license foo gets fixed.  So I think the thing to do is probably
to back my change out, and also find somebody who can fix nebiros, and hope we
end up with everything working.  If not, a better (ie correct) fix will need to
be found for the compiler flags problem.
looking into it...
Status: NEW → ASSIGNED

Comment 2

16 years ago
I can confirm that after I reverted back one version on configure and
configure.in by request of dmose that my Solaris builds started working again. I
vote for backing out dmose's changes(no offense dmose) and try again after the
1.0 branch.


-dcran--
(Assignee)

Comment 3

16 years ago
*** Bug 134007 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
Taking
Assignee: sspitzer → dmose
Status: ASSIGNED → NEW
(Assignee)

Comment 5

16 years ago
Original change backed out with r=sspitzer.  If the Solaris gcc problems this
fix was intended to address reappear, I'll open a separate bug for that.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
Spam for bug 129472
QA Contact: nobody → nobody
You need to log in before you can comment on or make changes to this bug.