Closed Bug 1341040 Opened 3 years ago Closed 3 years ago

Rename ServiceWorkerInfo::GetPrincipal() to make it clear its infallible

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: bkelly, Assigned: bkelly)

References

Details

Attachments

(1 file)

We should use Principal() instead of GetPrincipal().
Attachment #8839157 - Flags: review?(amarchesini) → review+
Pushed by bkelly@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a11eaf441b2c
Rename ServiceWorkerInfo::GetPrincipal() to Principal(). r=baku
https://hg.mozilla.org/mozilla-central/rev/a11eaf441b2c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.