Closed Bug 1341062 Opened 3 years ago Closed 3 years ago

Intermittent toolkit/content/tests/browser/browser_block_autoplay_media_pausedAfterPlay.js | The pause state of audio is corret. - true == false -

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: alwu)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(2 files)

Duplicate of this bug: 1341063
Component: Audio/Video → Audio/Video: Playback
All failures are linux32/64 and debug. Failures started on mozilla-inbound on Feb 20, but I don't see a likely cause.

Test was added fairly recently. Alastor - can you make this run more reliably?
Blocks: 1322505
Flags: needinfo?(alwu)
Assignee: nobody → alwu
Comment on attachment 8842716 [details]
Bug 1341062 - part1 : wait for audioplayback event to ensure the media element has been resumed.

https://reviewboard.mozilla.org/r/116488/#review118170
Attachment #8842716 - Flags: review?(amarchesini) → review+
Comment on attachment 8842717 [details]
Bug 1341062 - part2 : remove duplicated codes.

https://reviewboard.mozilla.org/r/116490/#review118172
Attachment #8842717 - Flags: review?(amarchesini) → review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5304ef02b51f
part1 : wait for audioplayback event to ensure the media element has been resumed. r=baku
https://hg.mozilla.org/integration/autoland/rev/19350704484d
part2 : remove duplicated codes. r=baku
Whiteboard: [stockwell fixed]
https://hg.mozilla.org/mozilla-central/rev/5304ef02b51f
https://hg.mozilla.org/mozilla-central/rev/19350704484d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.