Closed Bug 1341161 Opened 3 years ago Closed 3 years ago

Permaorange browser_localStorage_e10s.js | Uncaught exception - Error getting pref 'dom.ipc.keepProcessesAlive.web' when Gecko 54 merges to aurora on 2017-03-06

Categories

(Core :: DOM: Content Processes, defect)

54 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox-esr45 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 + fixed

People

(Reporter: philor, Assigned: asuth)

References

Details

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=78905574&repo=try

[task 2017-02-21T01:38:59.061544Z] 01:38:59     INFO - TEST-UNEXPECTED-FAIL | dom/tests/browser/browser_localStorage_e10s.js | Uncaught exception - Error getting pref 'dom.ipc.keepProcessesAlive.web'

[Tracking Requested - why for this release]: permaorange on the merge, closed trees, sadness.
Blocks: 1285898
Flags: needinfo?(bugmail)
Argh.  The test wants to be using Services.prefs.getIntPref(name, default), not the SpecialPowers.getIntPref(name) which tries to imitate the underlying API, but in fact does not take a default.

Because the "dom.ipc.keepProcessesAlive.web" pref is a synthetic pref only created when "dom.ipc.processCount" > 1, trees without multi-e10s enabled get sad like this.

Preparing and verifying the minimal fix now.
I am able to reproduce the test failure using the following without the patch, and things are happy with the patch:
  ./mach mochitest --setpref dom.ipc.processCount=1 dom/tests/browser/browser_localStorage_e10s.js

Also, I was tricked by the code at http://searchfox.org/mozilla-central/source/testing/mochitest/browser-test.js#106.  Although it would be quite cool for nsIPrefBrach.getIntPref to take an optional default, it does not.  I was thinking of Preferences.jsm which does support the signature Preferences.get(prefName, defaultValue).
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Flags: needinfo?(bugmail)
Attachment #8839309 - Flags: review?(amarchesini)
Attachment #8839309 - Flags: review?(amarchesini) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/45f5b39bd3c1011308d23dfd86c5df4ed1a1383d
Bug 1341161 - Handle "dom.ipc.keepProcessesAlive.web" pref not existing, fixing permaorange on aurora. r=baku
Tracking 54+ for the permaorange.
https://hg.mozilla.org/mozilla-central/rev/45f5b39bd3c1
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.