Editing draft uses default SMTP instead of specified account

RESOLVED DUPLICATE of bug 394216

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 394216
8 months ago
8 months ago

People

(Reporter: Andrei Boros, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Compose an email. (use the default account, but different from the default outgoing)
Save it as Draft.
Close TB
Open TB later.
Edit the draft. 
Try to send it.


Actual results:

TB attempts to send the email using the default outgoing account.
TB also attempts to newly save as draft in the IMAP folder corresponding to the outgoing account, not the one shown as "From"

I have several accounts configured.
account1 is the default.
account2
account3
account4
account5

The outgoing server entry corresponding to account3 is set as default in the outgoing list.
(note: each account has it's corresponding outgoing server set and properly mapped)

TB shows in composition window as "From" account1, but when I open the dropdown, it shows account3 as selected. If I manually set account1 again, then the message is sent as expected.

Normal composition and sending doesn't seem to be affected by this. 
I discovered this issue because account3 outgoing server doesn't have it's password stored and asks for it.


Expected results:

Context: multiple IMAP accounts, each with it's own folder tree.
A draft also has a "From" field saved and is actually saved in Drafts folder of the corresponding account. Thus account mapping is (should be) well defined.

Although the correct From is shown, the issue is about TB taking the default outgoing server instead of the From account associated outgoing server, which is wrong.

My default settings might seem off, but it is this way that I accidentally stumbled upon this issue. 

Note: the initial draft was written and saved via IMAP by another instance of an email client.

Comment 1

8 months ago
Currently working on this in bug 394216.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394216
You need to log in before you can comment on or make changes to this bug.