Avoid requiring a virtualenv for mach artifact

RESOLVED FIXED in Firefox 54

Status

defect
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla54
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(3 attachments)

No description provided.
Depends on: 1341214
Comment on attachment 8839360 [details]
Bug 1341215 - Vendor dlmanager.

https://reviewboard.mozilla.org/r/114040/#review116216

Can we just vendor mozregression? I think there's a mach command that would end up using it as well. 

Can we at least drop a link to the origin of this code in a comment at the top of each file?
Attachment #8839360 - Flags: review?(cmanchester) → review+
Comment on attachment 8839360 [details]
Bug 1341215 - Vendor dlmanager.

https://reviewboard.mozilla.org/r/114040/#review116218

Meant to cancel review for now. Copying these files from github (one of which doesn't have a license header) without making their origin clearer doesn't seem quite right.
Attachment #8839360 - Flags: review+
Comment on attachment 8839361 [details]
Bug 1341215 - Remove the dependency on the mozregression module for mach artifact.

https://reviewboard.mozilla.org/r/114042/#review116220

Thanks for the patches, this is a very welcome simplification.
Attachment #8839361 - Flags: review?(cmanchester) → review+
(In reply to Chris Manchester (:chmanchester) from comment #3)
> Comment on attachment 8839360 [details]
> Bug 1341215 - Remove the dependency on the mozregression module for mach
> artifact.
> 
> https://reviewboard.mozilla.org/r/114040/#review116216
> 
> Can we just vendor mozregression? I think there's a mach command that would
> end up using it as well. 

Vendoring mozregression would need vendoring at least BeautifulSoup, taskcluster, mohawk and colorama. That's too much for my taste.

> Can we at least drop a link to the origin of this code in a comment at the
> top of each file?

Sure, but looking deeper in all that, there needs to be some clarification about the license first :-/
Will file an issue on github.
(In reply to Mike Hommey [:glandium] from comment #6)
> Will file an issue on github.

Aha, issues are not enabled on github ; it looks like bugzilla is the place to file bugs for it.
Depends on: 1341976
It turns out the download manager part is also available separately on https://github.com/parkouss/dlmanager and only requires requests and six. We have both in the tree already, although six is in a weird location (testing/web-platform/tests/tools/six).
Comment on attachment 8840307 [details]
Bug 1341215 - Remove the dependency on the python taskcluster client module for `mach artifact`.

https://reviewboard.mozilla.org/r/114806/#review116516
Attachment #8840307 - Flags: review?(cmanchester) → review+
(Pushed reordered commits, no changes ; waiting for dependent bugs to land before landing this)
No longer depends on: 1341976
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/7d817a123f53
Vendor dlmanager. r=chmanchester
https://hg.mozilla.org/integration/autoland/rev/4f108fc57f7c
Remove the dependency on the mozregression module for mach artifact. r=chmanchester
https://hg.mozilla.org/integration/autoland/rev/f967d32a9efb
Remove the dependency on the python taskcluster client module for `mach artifact`. r=chmanchester
Blocks: 1343718
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.