Video on /contribute does not stop playing when closing modal

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: agibson, Assigned: rcmainak)

Tracking

({good-first-bug})

Production
good-first-bug

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 months ago
STR:

1.) Visit https://www.mozilla.org/contribute/
2.) Scroll down to the "Volunteering with Mozilla…" section and click the video play thumbnail graphic.
3.) When the modal opens, wait for the video to start playing.
4.) Close the modal using the (x) button top right.

Expected results:

The video should stop playing when the modal is closed.

Actual results:

The video continues to play in the back ground (audio can still be heard even though there is no image).
(Reporter)

Updated

8 months ago
(Reporter)

Updated

8 months ago
Keywords: good-first-bug
(Assignee)

Comment 1

8 months ago
I think I can fix it :)
(Reporter)

Comment 2

8 months ago
Thanks once again :)
Assignee: nobody → mozilianmainak
Status: NEW → ASSIGNED

Comment 3

8 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/4d8ce2d55cede4a81b00fbaf718e3ed3993c0d65
fix Bug 1341242 - Pause video playback when a user closes the modal on the /contribute page.

https://github.com/mozilla/bedrock/commit/2a1cc3e91403b39943d09a2859b14c4c950b3a2f
Merge pull request #4685 from RCMainak/bug_1341242

fix Bug 1341242 - Video on /contribute does not stop playing when closing modal

Updated

8 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.