If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Task completion rate survey on mozilla.org

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
7 months ago
5 months ago

People

(Reporter: Eric Renaud, Assigned: agibson)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 months ago
Set up link to survey (Survey Monkey)for task completion on mozilla.org
(Assignee)

Updated

7 months ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 1

7 months ago
Hi Peter,

Any direction for which pages you would like this survey to display on? I know you mentioned not showing it on the firefox download pages which makes sense, but what I'm curious about is if we want to show it pretty much *everywhere else*, or if showing it on a curated list of pages would be considered enough. Technically we could do it either way, but happy to discuss when you're around later today.
Flags: needinfo?(peter.german.bugs)

Comment 2

7 months ago
Hi Alex,

The link to the survey is here: https://www.surveygizmo.com/s3/3353529/Moz-org-Task-Completion-Rate

It should be displayed to our main locale only for now /en-US/.

Exclude the following pages:
/firefox/new/
/firefox/new/?scene=2
/firefox/[version]/firstrun
/firefox/plugincheck/ (I feel like we already know why people come here and if they're successful)

I've added Justin Crawford to review the survey and this list of pages as well.
Flags: needinfo?(peter.german.bugs) → needinfo?(hoosteeno)
(Assignee)

Comment 3

7 months ago
Some other pages I think we should exclude:

/firefox/[version]/whatsnew/ (in product page)
/firefox/[version]/tracking-protection/start/ (in product tour)
/firefox/features/ (this URL is redirected from old /firefox/firstrun/learnmore/ URLs)
/firefox/installer-help/ (may not be the appropriate time to launch a survey on someone)
/firefox/os/ (pages are currently being deprecated)
/firefox/channel/
/firefox/developer/
/firefox/all/
/firefox/feedback/ (in product page)

There may be a few more we need to exclude for UI reasons, which I'll add as I find them.
(Assignee)

Comment 4

7 months ago
Further to our discussion today:

- Survey is to be toggled off behind a feature switch. We'll turn it on a few weeks before the Universal Nav prototype goes out, and then gauge for change in the overall sentiment of responses.
- If someone clicks the survey link or closes the popup, never show them the survey again.
- If someone ignores the survey, don't show them again for (x) days.
(Assignee)

Comment 5

7 months ago
WIP version is now up on demo4: https://www-demo4.allizom.org/en-US/

Note: I've disabled the cookie check for now to make testing easier.

Comment 6

7 months ago
Looks good to me. Can we hook up the survey?
(Assignee)

Comment 7

7 months ago
(In reply to pgerman from comment #6)
> Looks good to me. Can we hook up the survey?

Sure, can you please provide the URL?

Comment 8

7 months ago
Comment 2 :D
(Assignee)

Comment 9

7 months ago
(In reply to pgerman from comment #8)
> Comment 2 :D

Oh, I'm being blind - forgive me :)
(Assignee)

Comment 10

7 months ago
Correct survey link is now in place on demo:

https://www-demo4.allizom.org/en-US/
(Assignee)

Comment 11

7 months ago
Ok the cookie that now hides the survey once seen / interacted with is now in place on demo 4.

For testing you will either have to clear either of the two cookies to see the survey again, or alternatively use a private window:

'moz-task-completion-survey-interaction'
'moz-task-completion-survey-shown'
(Assignee)

Comment 12

7 months ago
Created attachment 8840880 [details] [review]
GitHub pull request
(Assignee)

Comment 13

7 months ago
Peter,

I've added some logic to bedrock to automatically include the URL path as a query parameter to Survey Gizmo as discussed:

https://www-demo4.allizom.org/

(Note: for now I've disabled the cookie check, so the survey shows up every time to make testing easier).

I also added the related hidden fields to the survey form for both Date and Page. After completing the survey I can see both the Date and Page being populated correctly in the results page [1], so it looks like we don't need the custom JS that MDN used (assuming all we're really needing here is the page URL).

I can't seem to find a way to check the Google Spread Sheet however, so perhaps you could verify that all looks well?

[1] https://app.surveygizmo.com/explorer/report-summary/id/3353529
Flags: needinfo?(peter.german.bugs)

Comment 14

7 months ago
Last week I confirmed that this was working appropriately.
Flags: needinfo?(peter.german.bugs)

Comment 15

7 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/9b6dd4401ca5f7c66a2423c217beced6fbfb8e9b
[fix bug 1341425] Task completion rate survey on mozilla.org

https://github.com/mozilla/bedrock/commit/433619292bf1449c7d9b7c000429951cbb05c247
Merge pull request #4678 from alexgibson/bug-1341425-task-completion-survey

[fix bug 1341425] Task completion rate survey on mozilla.org

Updated

7 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED

Comment 16

6 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/cecd0890b2f06483af2a3d9183b8277aba132425
[bug 1341425] Rate limit task completion survey at 10%

https://github.com/mozilla/bedrock/commit/4f900871251930543e283424a60cb38bf3a4e635
Merge pull request #4717 from alexgibson/bug-1341425-rate-limit-survey

[bug 1341425] Rate limit task completion survey at 10%
Flags: needinfo?(hoosteeno)
(Assignee)

Comment 17

5 months ago
Survey is complete - reopening this to remove the survey code.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 18

5 months ago
Created attachment 8865383 [details] [review]
GitHub pull request

PR to remove survey code from all pages.

Comment 19

5 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/ee8e64faa0d4c6bddaff034fa796e6ced59c7b44
[fix bug 1341425] Remove task completion survey code

https://github.com/mozilla/bedrock/commit/23f68a52fe10fa1017e65959eef45f2fe40ffa68
Merge pull request #4809 from alexgibson/bug-1341425-remove-mozorg-survey-code

[fix bug 1341425] Remove task completion survey code

Updated

5 months ago
Status: REOPENED → RESOLVED
Last Resolved: 7 months ago5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.