Ship Report Site Issue button to Dev Edition channel

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: miketaylr, Assigned: miketaylr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Currently our Report Site Issue button is Nightly-only. It's been about a month and nothing terrible has happened, so let's ship it to Dev Edition.
Is this feature planned to make it to Release, or is it always going to stay in pre-release versions? It is not currently covered by our Firefox Privacy Policy: https://www.mozilla.org/en-US/privacy/firefox/

There's a "get out of jail free" clause for pre-release ("Our pre-release versions (Beta, Aurora/Developer Edition, Nightly, and TestFlight) are still under active development and may contain new features or have different privacy characteristics.") but if this is planned as a Release feature we will need to add it to the Policy.
Flags: needinfo?(miket)
Hey Daniel -- the current plan is for this feature to not ship past Beta (at some future, undetermined point...).

(FWIW, the webcompat.com privacy statement was reviewed by Mozilla legal: https://webcompat.com/privacy)
Flags: needinfo?(miket)
Assignee: nobody → miket
Should probably get some kind of product sign-off before landing these patches...
Bryan, is there an approval process for this type of thing? Thanks!
Flags: needinfo?(clarkbw)
We have several forms to fill out and those will need to be presented before the magistrate.  As of now Nightly is on an extended train and there's no uplift to Aurora.  So your next option is actually going to be Beta or you'll need to wait a couple of weeks for the DevEdition merge to happen so you can identify DE users from Beta users.
Flags: needinfo?(clarkbw)
In other words, approved.  But I don't know that you can actually target DE right now.
Thanks! 2 follow up questions:

1) Do you know if there be some mechanism in the future to target just DE users? #ifndef RELEASE_OR_BETA will sort of be a lie very soon. 

2) is there a bug for the first DE <-> Beta merge I can follow along? I'm happy to hold off on this feature until after that.
Flags: needinfo?(clarkbw)
1) Yes, take a look in bug 1354262 The DE flag is now a runtime flag that you can look at and know if this is a DE repack of Beta.

2) bug 1354262 and bug 1353825
Flags: needinfo?(clarkbw)
Depends on: 1362102
Things seem to have settled down wrt DE changes. AFAICT, these patches should still apply.
Attachment #8858322 - Flags: review?(gijskruitbosch+bugs)
Attachment #8858323 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8858322 [details]
Bug 1341438. Part 1 - Enable Report Site Issue for DevEdition + Nightly.

https://reviewboard.mozilla.org/r/130282/#review146940
Attachment #8858322 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8858323 [details]
Bug 1341438. Part 2 - Update CUI tests to know how to handle an extra button in DevEdition.

https://reviewboard.mozilla.org/r/130284/#review146942

rs=me (and also, sorry!) assuming this passes on try both on nightly and when run as an aurora simulation. The sheriffs should be able to help with running one of those.
Attachment #8858323 - Flags: review?(gijskruitbosch+bugs) → review+
Thanks Gijs! 

I built an aurora and ran tests locally, but I'll figure out how to get an aurora try going.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=81b0403aefb1&selectedJob=102066415 is Nightly -- green except for a single unrelated intermittent.
Here's a linux64-devedition try run on the beta branch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b3a340c5c58a0ff09e1ff5dacf8a531d9f00cce2. All green (after pushing tweaks for test failures).

And https://treeherder.mozilla.org/#/jobs?repo=try&revision=e05bcd1f31c837ce89f5a48cc1bcd456dc104487&selectedJob=102952241 on Nightly -- all green.
Pushed by mitaylor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/99605b5c6d20
Part 1 - Enable Report Site Issue for DevEdition + Nightly. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/5b5a6615aeac
Part 2 - Update CUI tests to know how to handle an extra button in DevEdition. r=Gijs
Depends on: 1368920
(In reply to Mike Taylor [:miketaylr] (traveling May 30 - June 5 for a conf) from comment #20)
> Here's a linux64-devedition try run on the beta branch:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=b3a340c5c58a0ff09e1ff5dacf8a531d9f00cce2. All green
> (after pushing tweaks for test failures).

That try build has a milestone of 55.0a1. Looks like it was branched from central, not beta. Running it shows NIGHTLY_BUILD is set, RELEASE_OR_BETA is unset, MOZ_DEV_EDITION is set.

My own DevEd builds from beta show NIGHTLY_BUILD is unset, RELEASE_OR_BETA is set, MOZ_DEV_EDITION is set.

I think the above patches won't work as-is and need to check MOZ_DEV_EDITION, too.
(In reply to Jan Steffens from comment #23)
> I think the above patches won't work as-is and need to check
> MOZ_DEV_EDITION, too.

Yes, it doesn't work on aurora 55.0b11[1]. It's still a nightly only extension. In addition to that, do we have plan to enable it for beta users?

[1] https://www.mozilla.org/zh-TW/firefox/developer/
Flags: needinfo?(miket)
(In reply to Astley Chen [:astley] from comment #24)
> (In reply to Jan Steffens from comment #23)
> > I think the above patches won't work as-is and need to check
> > MOZ_DEV_EDITION, too.
> 
> Yes, it doesn't work on aurora 55.0b11[1]. It's still a nightly only
> extension. In addition to that, do we have plan to enable it for beta users?
> 
> [1] https://www.mozilla.org/zh-TW/firefox/developer/

Hmm, it's working as expected in my 55.0b11 DevEdition. I wonder if it's somehow related to localized version?

No, no current plan to move to Beta yet (but probably in near future once we have better tooling to handle incoming issues (duplicates, prioritization, etc)).
Flags: needinfo?(miket)
Astley -- I just downloaded the zh-TW edition and it seems OK for me: https://cloudup.com/c8Hp7Q3r9RK
What does extensions.webcompat-reporter.enabled say in about:config for you?

(in theory it should be true, http://searchfox.org/mozilla-central/source/modules/libpref/init/all.js#4939-4944)
Flags: needinfo?(aschen)
(just checked in a new profile as well: https://cloudup.com/cU4sV7E0Pnj)
Well, it's really odd as I re-tested the zh-TW version from aurora channel and webcompat addon is still not in the hamburger menu.

More than that, the pref extensions.webcompat-reporter.enabled is true.
I have no idea what's going wrong here.
Flags: needinfo?(aschen) → needinfo?(miket)
Very strange... if you click "customize", do you see the addon icon in the CUI palette (with the other options/icons)?

Eric, can you reproduce what Astley is describing?
Flags: needinfo?(miket) → needinfo?(etsai)
(In reply to Astley Chen [:astley] from comment #28)
> Created attachment 8890743 [details]
> aurora-no-reporter-addon.png
> 
> Well, it's really odd as I re-tested the zh-TW version from aurora channel
> and webcompat addon is still not in the hamburger menu.
> 
> More than that, the pref extensions.webcompat-reporter.enabled is true.
> I have no idea what's going wrong here.

Is the system add-on listed in about:support as enabled? See also bug 1371273.
I guess I've found the STR.

STR:
1. Double click on downloaded aurora DMG file, e.g. "Firefox 55.0b12.dmg" and a Finder window pop up and guide you to install FirefoxDeveloperEdition.app to Application folder.
2. I don't do that but instead launch Firefox app from this Finder window.
3. Firefox launched and no webcompat reporter extension appears in menu and CUI.

If I launch Firefox from Application folder, everything becomes normal.
Launch from Finder window seems a rare case as general users won't do that.
That said, I'm still wondering what's the difference in this two launch paths.
Flags: needinfo?(etsai)
Thanks! Can you file a new bug here in Web Compatibility Tools::General?
You need to log in before you can comment on or make changes to this bug.