Common actions result in probably unnecessary red HTML warnings when posting

RESOLVED FIXED

Status

support.mozilla.org - Lithium
Ask a Question Workflow
RESOLVED FIXED
10 months ago
6 months ago

People

(Reporter: John99, Unassigned, NeedInfo)

Tracking

Details

(Reporter)

Description

10 months ago
I note other contributors are seeing this problem, or at least these messages.
One method of creating this it to post in a forum and paste in to the post you are writing the content of a "common forum response". 

The message is in red under the post being written or previewed
> Your post has been changed because invalid HTML was found in the message body. 
>The invalid HTML has been removed. 
>Please review the message and submit the message when you are satisfied.

This may be  seen even if you are only in Rich Text Mode and not using HTML mode. I can write an STR by repeating the actions I took to create the following post
> Crashes forum respnse needs updating - no linkification in Lithium
> https://support.mozilla.org/t5/Knowledge-Base-L10n-Discussions/Crashes-forum-respnse-needs-updating-no-linkification-in-Lithium/m-p/1365873

The related discussion thread where others also report seeing these errors is
> Red HTML errors warning on posts. Anyone else seeing this.
> https://support.mozilla.org/t5/SUMO-community-discussions/Red-HTML-errors-warning-on-posts-Anyone-else-seeing-this/m-p/1365844#M25643

I will try to work out a simpler STR, although I imagine there are multiple causes of the error, and some may be valid. 

The error under the post is a minor annoyance if it continues on to post afterwards, but if the actions done are common and expected and HTML mode is not being used in my opinion such an error should not be displayed it should silently and transparently deal with any problems.

In some cases as in the thread I give as an example a message also appears at the top above the post white on a red background 
> Correct the highlighted errors and try again.
In that particular case I saw no highlighted errors.
That itself is a bug, it should clearly highlight errors if it displays such a message.
The post in fact posted on hitting the blue post button without the need to correct anything.
Again that is wrong if the such a message displays action should be required else it should not and need not display.

Comment 1

10 months ago
It seems that I can trigger the red HTML warning message if I go back in a posting that I am writing and attempt to add a hyperlink in the middle of Rich Text.At least in the SUMO-community-discussions fora. Haven't tried that in Privacy-Security or Messages - all three areas seem to work a bit differently, and HTML has other quirks that I don't get in Rich Text mode.

Comment 2

10 months ago
I tried previewing and then posting a copy/paste from the same common forum response, https://support.mozilla.org/t5/Common-Responses/Forum-Response-Clean-reinstall/ta-p/26432  into the Rich Text editor reply box of a thread in the SUMO Community Discussions forum.  I tried  using two different profiles with different permissions.

I DO NOT see any errors when signed in with my AliceWyman "Site Moderator" profile. 

I DO see the error when signed in to my wymette "New Contributor" profile.  After the copy/paste and previewing my post, I  see the error message, in red, "Your post has been changed because invalid HTML was found in the message body. The invalid HTML has been removed. Please review the message and submit the message when you are satisfied." I'm able to post the reply after pressing the Post button eithr once or twice.

See my posts in this discussion thread for details:
https://support.mozilla.org/t5/SUMO-community-discussions/Red-HTML-errors-warning-on-posts-Anyone-else-seeing-this/td-p/1365248
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

10 months ago
Component: Lithium Migration → Ask a Question Workflow
Product: support.mozilla.org → support.mozilla.org - Lithium
Assignee: nobody → pmcclard
Found this thread on Lithium's support forum. 

https://community.lithium.com/t5/Community-Strategy/Logic-for-Which-HTML-Tags-Are-Allowed-Disallowed/m-p/217826/highlight/true#M1523

>Likewise! Very curious about the logic as well. We had to allow employees and super users to use advanced HTML because they kept running into errors due to multi level bulleted lists - which to me SHOULD qualify as simple HTML.  Not 100% thrilled with that move, but it trumps getting daily reports from people having issues, and we haven't seen any abuse so far.

Should be a fairly easy fix, but I'd like to understand the impact of enabling Advanced HTML before turning it on.
Assignee: pmcclard → nobody
John99 can you provide a specific common response we can work from to identify what html is working and not working from the current common responses before we start editing.
Flags: needinfo?(John99-bugs)
(Reporter)

Comment 5

8 months ago
Is this something I can test on a read only Lithium site ? probably not.

We had a problem in the original beta testing of Lithium that we just did not have realistic permissions. At least initially we were either Site Admins or ordinary visitors.  That made it impossible to properly test out things like the KB documents workflow. This problem will presumably need to be tested on a live Lithium site that is not read only.

As I posted in another bug
> bug 1340917 comment 6  
> ... What is the current position on the Read Only Lithium site is it worth me looking at what happens on that or is it better tyo wait until we move back to Lithium. Also if Lithium changes are being made do contributors get access to the Lithium stage equivalent so we can test things out before they go live. And the ability once there to test as users with differing permissions/roles i.e. as our own site moderator role, but also as an ordinary contributor, and an ordinary visitor ?

I guess we need clarification an the possibilities of contributors being able to access and test Lithium.

My question in the bug was not so much about what did and did not work. If I recall correctly nested and mixed ordered/unordered paragraphs were not provided by the rich text editor but and may have been odd when you tried direct HTML. 

As I was saying in comment0 this sort of error occurred even when I was not deliberately using HTML ditectly.
>This may be  seen even if you are only in Rich Text Mode and not using HTML mode. I can write an STR by repeating the actions I took to create the following post
> Crashes forum respnse needs updating - no linkification in Lithium
> https://support.mozilla.org/t5/Knowledge-Base-L10n-Discussions/Crashes-forum-respnse-needs-updating-no-linkification-in-Lithium/m-p/1365873

This bug was assigned to Patrick but is now unassigned are you assigning it to yourself now Rachel ?
(Not yet had time to see the platform video from Thursday 26th but I see it is available already on air mo that's good)
Flags: needinfo?(John99-bugs)

Comment 6

7 months ago
This seems to be a permission problem. The use of advanced HTML was only available to certain categories of users i.e. Admins and Moderators. 

We have changed the permissions so that anybody with a contributor role can use advanced HTML.

However we cannot test the impact of this and/or whether this causes any other issues until we are back on Lithium.

I will close this as fixed for now.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
(Reporter)

Comment 7

7 months ago
So if this is fixed is it not possible to test it out. 
Can we test this on stage ? 
Can we test it on Lithium Prod ?


At this rate we are possibly going to have more than one or two bugs marked as fixed before we rollforward but no confirmation they are fixed until after we roll forward. I am not sure that is a very satisfactory situation.

Note I was seeing this error when NOT tying to use HTML mode never mind trying to use advanced HTML. (Not actually sure how I would use ''advanced'' HTML on Lithium)

Also looking at
> https://hwsfp35778.lithium.com/t5/SUMO-community-discussions/Red-HTML-errors-warning-on-posts-Anyone-else-seeing-this/m-p/1365844#M25643 
That is the equivalent link to the thread mentioned in comment 0 I see that Scribe mentions often seeing the problem & Geof is only an ordinary contributor not an Admin Or Mod

Marking myself NI to review and test this when permitted.
And NI Madalina as otherwise the fixed bug may not get reviewed.
Flags: needinfo?(mana)
Flags: needinfo?(John99-bugs)

Comment 8

7 months ago
You can test it on prod. All contributors can access the prod instance by using the hwsfp link.

The only request is that you DO NOT reply to any threads or do anything that interacts with users as this will get messy. Create a test thread instead (there is already one for Admin test purposes created).
Flags: needinfo?(mana)
(Reporter)

Updated

6 months ago
See Also: → bug 1370447
You need to log in before you can comment on or make changes to this bug.